Register - Login
Views: 91326610
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - Stats - Latest Posts - Color Chart - Smilies
05-21-18 04:19:32 AM

Jul - Posts by Hiccup
Pages: 1 2 3 4 5 6 7 8 9 10 ... 24 25 26 27 28 29 30 31 32 33
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 6/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-01-09 02:47:53 AM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-01-09 05:41 AM) Link
Thanks and what is sprite 43 its unused but in the sprites set lists it shows it under chain chomps why, is it a beta chain chomp? i'm also confused about timed event activaters, mass event activaters, and boss activaters
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 9/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-06-09 02:12:01 PM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-11-09 11:30 AM) Link
Treeki, About views - are all the view settings in part of the header file, or are the options in sprites like:
264 (unknown), 198 (Scroll Control left??), 199 (Scroll Control right??) ?
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 10/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-14-09 03:39:41 AM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-14-09 03:43 AM) Link
Originally posted by m64m
@ Treeki - I'm currently using the editor to make a much more difficult version of the game. For the most part, editing has been fine. I've progressed to World 1-4 already. I finished editing the first area, but area 2 and 3 don't open. The editor can't read them for some reason. Does anyone else have this problem? If not, is there a way to patch those two areas? (side note: All of the other areas in World 1 work fine) Any help is much appreciated ^__^


I have also had that problem with 1-4 - area 2 and 3

and Treeki also is the music and sound settings in the header file or sprites?
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 11/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-15-09 01:00:34 PM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-15-09 01:52 PM) Link
In the hex editor you have only explianed obout block 8 do you know the functions of the other blocks and are all the camera view settings in block 8 also i am having lots of problems with warps and conected pipes.
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 13/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-16-09 02:54:09 AM, in Original NSMB Hacking Thread (Archived) Link
By Warps i mean 155: Warp to Level sprite

when i use it it crashes the game or or puts me to the begining of the level (with the entrance i made)

and i cannot use the connected pipes (the ones from 7-A) at all , even if the scrolling does not work they just dont work.
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 14/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-16-09 01:56:53 PM, in Original NSMB Hacking Thread (Archived) Link
Originally posted by Treeki
Show me the exact sprite data you're using for it?


This sprite data brings mario back to the begining :00 00 02 01 00 00, but i'm trying to make it go to an entrance with this data:

X: 1537 Y: 448

Normal

Camera X: 0

Camera Y: 0

Entrance Number: 1

Destination Area: 0

Destination Entrance: 0

Connected Pipe ID: 0

View: 0

(Tick) Exit Only

I'm not sure about what warp to level sprite data made the game crash.

and trekki - you know bosses in other levels are glitchy and can crash to fix that is it somthing in the header file or for bowser is it somthing to do to with sprite 280?
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 16/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-18-09 02:39:58 AM, in Original NSMB Hacking Thread (Archived) Link
Treeki - two questions

question 1 -
in the header is there sound sets because i put dry bones in 1-1 and jump on them they make the goomba stomp sound and not the click clock sort of noise that happens in towers and castles.

question 2 -
about sprite 21 mega goomba, can it be stomping around when you enter the area its in (like a normal goomba) because i want to make it in to a regular enemy. When you use the boss activater you have to wait for it to grow.
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 17/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-18-09 11:18:00 AM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-18-09 11:22 AM) Link
Originally posted by Treeki
Originally posted by Hiccup
Treeki - two questions

question 1 -
in the header is there sound sets because i put dry bones in 1-1 and jump on them they make the goomba stomp sound and not the click clock sort of noise that happens in towers and castles.

This is kind of interesting - I don't have speakers so I never noticed any differences like this. I wonder if any other enemies are affected. For now I'm not really sure what you can do.



the other enemies is the money bag (no bouncing sound)

and the giant hammer bro when it ground pounds mario gets shaken but does not say ow

another question how can i change the jumping sound to the classic smb jumping sound (mega mario jumping sound)

PS sorry i ask a lot of questions hope thats ok!
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 18/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-18-09 11:23:39 AM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-18-09 11:23 AM) Link
How'd ya hack the sound data?
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 19/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-18-09 01:39:54 PM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-21-09 10:11 AM) Link
I give up with - http://kiwi.ds.googlepages.com/sdat.html

...

there could be some sort of pointer table like where it points the jumping sound to be the the sound for somthing else?

2 Questions
1.There is a bug in the editor when you maximise the second window (level selecter) the hex edit butten dosent move it stays in the middle of the screen

2.I know its not in the editor but how to i edit tiles (what program and how to use it please)

Edit: Ive got a realy big problem with 1-2's camera. It the worst camera in the game , ive basically tried everything i can can any one fix it? Please email it fixed to me or just post the link here. Ive put the nml files and the bins in a zip.

Here is the link http://www.mediafire.com/?njxmtmgmayt
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 22/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-20-09 02:52:39 AM, in Paper Mario Hacking Link
What about super paper mario (wii)?
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 23/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-20-09 02:54:51 AM, in how to create bowser with nsmb editor Link
Ok sorry
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 24/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-22-09 02:59:05 AM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 09-10-12 03:30:49 AM) Link
Originally posted by Treeki

Place it exactly at the bottom left. (Make sure the X and Y are divisible by 16 - I'm not sure if the game needs completely exact positioning, but I'm pretty sure it does)



Thats not my problem (are you talking about entrances?). When i play it back it no$gba and i go forward then jump into the water and then the camera goes strange it mostley does not let mario go past but it does if i swim mario down lower the camera sort of flickers backwards and forwards and lets me past.

I just want sombody to fix it so the camera moves smoothly to the end of the level with the pipe and the blocks.

my email is [removed]

and awnsers to my other questions?

or just upload and put a link to it on this thread
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 25/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-22-09 11:33:29 AM, in Original NSMB Hacking Thread (Archived) Link
I'm fine now with the level ive started a new one but i might use the design again

and a Question

I know its not in the editor but how do i edit tiles. What program and how to use it please.
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 26/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-22-09 12:15:19 PM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-22-09 12:44 PM) Link
Treeki i think its hard coded in to nsmb to make 1-2's camera such a pain! I replaced the whole of the level with 2-A (with nml) and i changed it how i wanted it and the same camera problem has happend!
IM SO MAD AND CONFUSED!

EDIT: Do i need to compress the files?

and do i open those files in tile molster or open the rom?

where do i get tile molster? please give me a link from where you got it from cause there so many links on google
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 27/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-23-09 02:13:59 AM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-23-09 02:37 AM) Link
Originally posted by m64m
Tile Molester - h ttp://www.zophar.net/download_file/2736 (broke the link on purpose)

You need Java 1.4.0 or higher to run it.

To make it work for DS games:
~~~~~~~~~~~~~~~~~
1. Open tmspec.xml in Notepad.
2. Find */palettefilters**.
3. Add this before:
*palettefilter extensions="bin" colorformat="CF00" size="1024" offset="0" endianness="little"**
*description**DS ripped _ncl.bin palette*/description**
*/palettefilter**
*palettefilter extensions="enpg" colorformat="CF00" size="512" offset="65536" endianness="little"**
*description**NewSMB ENPG image (8bpp linear)*/description**
*/palettefilter**

4. Save it, reopen TM.
~~~~~~~~~~~~~~~~~
^ Originally posted by Treeki

{replace "*" with "<" and "**" with ">" for # 2 and 3}


~~~~~~~~~~~

Although, I did that, and NSMB still doesn't display properly in TM. :/ Any help Treeki? I tried all the different codecs @.@


Theres no exe in the link you sent me?

EDIT: I just double clicked on it like an exe and it worked!
EDIT: Do i open the rom or the files extracted from the rom if i need to extract thr files do do i press lz decompress?
EDIT: And what do you mean " for # 2 and 3} "
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 28/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-25-09 02:41:11 AM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-27-09 01:20 PM) Link
Thanks Treeki and m64m
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 29/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-27-09 01:24:50 PM, in Original NSMB Hacking Thread (Archived) Link
Treeki 3 Questions

1. In the obj and BG_ncg do you know what is tileset 0 (? blocks/bricks)

2. Tile molster does not have the file i extracted in surported files

3. I opened the file by pressing all files on tile molster but when opened it it was just a jumble of colours and i set it to 4bpp linear reverse order!
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 30/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-28-09 04:03:54 AM, in Original NSMB Hacking Thread (Archived) Link
Originally posted by Treeki

Tileset 0 is d_2d_A_J_jyotyu_ncg.bin. The palette is d_2d_A_J_jyotyu_ncl.bin in the bg_ncl folder (it's also compressed).



I have extracted and de-compressed those files. Then i opened d_2d_A_J_jyotyu_ncg.bin in Tile Molester
and it comes up with this http://img43.imageshack.us/img43/5130/screenhunter01jun280901.jpg,

Do i need to do somthing with the pallete files?
Hiccup
Member
Disgustingly Naive Smartass
Level: 54


Posts: 33/746
EXP: 1168470
For next: 65400

Since: 05-19-09


Since last post: 20 days
Last activity: 12 hours

Posted on 06-29-09 03:21:11 AM, in Original NSMB Hacking Thread (Archived) (last edited by Hiccup at 06-29-09 03:25 AM) Link
Ive made it display right on tile molster but when i import the file back into nsmb with the editor and press LZ compress

and when i test it in nocash i get this



weird dots in the background (i didint try to edit the background)

and when i bumped the ? block the what should be the emty block went corupted

(i also changed the coins and ? blocks and bricks but they didnt change)
Pages: 1 2 3 4 5 6 7 8 9 10 ... 24 25 26 27 28 29 30 31 32 33
Jul - Posts by Hiccup




Rusted Logic

Acmlmboard - commit 5d36857 [2018-03-03]
©2000-2018 Acmlm, Xkeeper, Inuyasha, et al.

22 database queries, 54 query cache hits.
Query execution time: 0.174151 seconds
Script execution time: 0.029633 seconds
Total render time: 0.203784 seconds
Memory used: 1310720