Register - Login
Views: 87328183
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - JCS - Stats - Latest Posts - Color Chart - Smilies
11-18-17 02:59:30 PM

Jul - NSMB Hacking (Archive) - Help/Questions thread. ASK QUESTIONS HERE! New poll - New thread - New reply
Pages: 1 2 3 4 5 6 7 8 9 10 ... 56 57 58 59 60 61 62 63 64 65Next newer thread | Next older thread
limon
Random nobody
Level: 7


Posts: 1/8
EXP: 1100
For next: 348

Since: 05-31-11


Since last post: 6.0 years
Last activity: 6.0 years

Posted on 05-31-11 09:21:31 AM Link | Quote
@dirbaio

Could you tell me details about ASM hack?
I can examine which address contains specific data, but I don't know how to modify it in the game.

Sorry for my poor English.
limon
Random nobody
Level: 7


Posts: 2/8
EXP: 1100
For next: 348

Since: 05-31-11


Since last post: 6.0 years
Last activity: 6.0 years

Posted on 05-31-11 09:42:56 AM Link | Quote
Originally posted by shadeyshaney
well im still finishing the big multiplayer level almost like one in single player so ill let u know soon

eh with the volcano level in world 8 ( i think its 8-6 ) the lava goes up BUT i want to make it slower
the command is 00 00 02 F0 10 00 for that lava sprite but i want to make it go slower.
which one controls the speed?


sprite 241 Lava

ID 00 SS HH V0 00

ID:Activator ID
SS:speed
HH:the height it will rise
V:visible (1=make the lava visible)
shadeyshaney
Member
Level: 17


Posts: 53/59
EXP: 23417
For next: 1326

Since: 07-28-10


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 05-31-11 10:17:45 AM (last edited by shadeyshaney at 05-31-11 02:29 PM) Link | Quote
thanks alot
just another question, i imported a tileset to my level and for some reason now there are white blocks and parts around them. any idea why?

EDIT!:never mind i got it, just had to get rid of the white bits in the pallette thing
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 424/467
EXP: 530209
For next: 34837

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 06-04-11 01:37:19 PM Link | Quote
does ANYONE here know, where the 2d textures for the world icons are?
If you are on the world map, on the touchscreen there are the 8 icons you can touch to switch the current world.
WHERE are these??? One time, I found them, but that was long time ago! I thought they were in the UI_studio folder
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 1249/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 06-05-11 08:10:37 AM Link | Quote
Yeah, they were on the UIStudio folder. look through them again. Keep in mind that they are probably 4bpp
I don't remember the filenames either.
ray
Member
Level: 36


Posts: 282/321
EXP: 291282
For next: 16828

Since: 11-10-10


Since last post: 6.0 years
Last activity: 3.0 years

Posted on 06-05-11 08:13:41 AM Link | Quote
Originally posted by dirbaio
Yeah, they were on the UIStudio folder. look through them again. Keep in mind that they are probably 4bpp
I don't remember the filenames either.


NsmB_PrO and I looked both several times... NOTHING. We only know, that we found them long time ago with TileMolester
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 425/467
EXP: 530209
For next: 34837

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 06-05-11 08:18:33 AM Link | Quote
Originally posted by ray
Originally posted by dirbaio
Yeah, they were on the UIStudio folder. look through them again. Keep in mind that they are probably 4bpp
I don't remember the filenames either.


NsmB_PrO and I looked both several times... NOTHING. We only know, that we found them long time ago with TileMolester

Yeah, today I opend ALL the ncg files and ALL the ncl files, so I have all in the editor. If they were 4bpp, i switched 4bpp mode on. NOTHING at all
ray
Member
Level: 36


Posts: 286/321
EXP: 291282
For next: 16828

Since: 11-10-10


Since last post: 6.0 years
Last activity: 3.0 years

Posted on 06-07-11 09:57:06 AM Link | Quote
I have a problem with the lava sprite ._. My sprite data is: 35 00 02 15 00 00
Means: When 35 is activated, it should move 15 blocks up with the speed 2. But it doesnt move at all Also when i set a other activator id
limon
Random nobody
Level: 7


Posts: 3/8
EXP: 1100
For next: 348

Since: 05-31-11


Since last post: 6.0 years
Last activity: 6.0 years

Posted on 06-07-11 10:59:30 AM Link | Quote
I modified a lava or quicksand tile which has an animation.
But it doesn't work well... So, is it possible to use custom animation tiles?
limon
Random nobody
Level: 7


Posts: 4/8
EXP: 1100
For next: 348

Since: 05-31-11


Since last post: 6.0 years
Last activity: 6.0 years

Posted on 06-07-11 11:12:33 AM Link | Quote
Originally posted by ray
I have a problem with the lava sprite ._. My sprite data is: 35 00 02 15 00 00
Means: When 35 is activated, it should move 15 blocks up with the speed 2. But it doesnt move at all Also when i set a other activator id



I think you activate a wrong ID.

sprite data : 35 00 02 15 00 00

"35" is hexadecimal number. So, you have to activate 53 to raise the lava (if you use NSMBe5.2).
ray
Member
Level: 36


Posts: 288/321
EXP: 291282
For next: 16828

Since: 11-10-10


Since last post: 6.0 years
Last activity: 3.0 years

Posted on 06-07-11 11:22:59 AM Link | Quote
Originally posted by limon
Originally posted by ray
I have a problem with the lava sprite ._. My sprite data is: 35 00 02 15 00 00
Means: When 35 is activated, it should move 15 blocks up with the speed 2. But it doesnt move at all Also when i set a other activator id



I think you activate a wrong ID.

sprite data : 35 00 02 15 00 00

"35" is hexadecimal number. So, you have to activate 53 to raise the lava (if you use NSMBe5.2).


Yay! thank yoU
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 431/467
EXP: 530209
For next: 34837

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 06-07-11 11:53:22 AM Link | Quote
Originally posted by limon
I modified a lava or quicksand tile which has an animation.
But it doesn't work well... So, is it possible to use custom animation tiles?

if you want to edit those 3d textures (nsbtx-file), you have to modify the palette code as well.
But this is not easy. ray and me were adding random numbers to NSBTX-Files' Palette Codes, until they had the right colours
We dont know, which numbers are what colours
limon
Random nobody
Level: 7


Posts: 5/8
EXP: 1100
For next: 348

Since: 05-31-11


Since last post: 6.0 years
Last activity: 6.0 years

Posted on 06-07-11 12:50:08 PM Link | Quote
Originally posted by NsmB_PrO
Originally posted by limon
I modified a lava or quicksand tile which has an animation.
But it doesn't work well... So, is it possible to use custom animation tiles?

if you want to edit those 3d textures (nsbtx-file), you have to modify the palette code as well.
But this is not easy. ray and me were adding random numbers to NSBTX-Files' Palette Codes, until they had the right colours
We dont know, which numbers are what colours




Thanks a lot. I'll try it.
ray
Member
Level: 36


Posts: 294/321
EXP: 291282
For next: 16828

Since: 11-10-10


Since last post: 6.0 years
Last activity: 3.0 years

Posted on 06-11-11 06:04:40 AM Link | Quote
In revision 156 should be some new musics to choose in the view settings. One time i tested it, i saw them. But now, when i need them, they are not shown o0 Why?
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 438/467
EXP: 530209
For next: 34837

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 06-11-11 02:40:50 PM Link | Quote
I know, this question is frequntly asked by me, but:
WHY is the Vine - Sprite crashing the ROM, when I come near it???
When I enter the 16x16 block, where the vine sprite is, the level crashs

I looked into nintedos levels AND I made it completely the same ;(
xxxzzz1
Random nobody
Level: 4


Posts: 2/2
EXP: 137
For next: 142

Since: 06-12-11


Since last post: 6.0 years
Last activity: 6.0 years

Posted on 06-12-11 11:05:06 AM Link | Quote
Emmmm, Were are the emulators? I cant find any.
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 1254/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 06-12-11 11:18:59 AM Link | Quote
Originally posted by NsmB_PrO
I know, this question is frequntly asked by me, but:
WHY is the Vine - Sprite crashing the ROM, when I come near it???
When I enter the 16x16 block, where the vine sprite is, the level crashs

I looked into nintedos levels AND I made it completely the same ;(


I think it needs another extra sprite set. Try to look at the sprite sets in the original level and try to set the same ones in your level, one by one, to see what's the needed one...
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 441/467
EXP: 530209
For next: 34837

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 06-12-11 12:00:39 PM (last edited by NsmB_PrO at 06-12-11 12:01 PM) Link | Quote
Ok, I will.
And then I will report it here
I have already a presumption what it could be. Probably it is a combination of the rope Sprite set AND the vine set
ray
Member
Level: 36


Posts: 298/321
EXP: 291282
For next: 16828

Since: 11-10-10


Since last post: 6.0 years
Last activity: 3.0 years

Posted on 06-12-11 01:07:55 PM Link | Quote
Originally posted by NsmB_PrO
Ok, I will.
And then I will report it here
I have already a presumption what it could be. Probably it is a combination of the rope Sprite set AND the vine set


Yeah, that's it. I set the vine Sprite set and the rope sprite set and it worked. I think the vine sprite loads the texture, but it hasn't a sprite data. The vine and the rope are the same, without the texture. So the vine loads the data from the rope. Can this be?
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 442/467
EXP: 530209
For next: 34837

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 06-12-11 01:11:02 PM Link | Quote
I thought exactly the same
but thanks for testing^^
Pages: 1 2 3 4 5 6 7 8 9 10 ... 56 57 58 59 60 61 62 63 64 65Next newer thread | Next older thread
Jul - NSMB Hacking (Archive) - Help/Questions thread. ASK QUESTIONS HERE! New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 2f1bc75 [2017-08-27]
©2000-2017 Acmlm, Xkeeper, Inuyasha, et al.

30 database queries, 13 query cache hits.
Query execution time: 0.213335 seconds
Script execution time: 0.022630 seconds
Total render time: 0.235965 seconds