Register - Login
Views: 85788690
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - JCS - Stats - Latest Posts - Color Chart - Smilies
09-26-17 06:36:20 PM

Jul - NSMB Hacking (Archive) - Help/Questions thread. ASK QUESTIONS HERE! New poll - New thread - New reply
Pages: 1 2 3 4 5 6 7 8 9 10 ... 56 57 58 59 60 61 62 63 64 65Next newer thread | Next older thread
frjd
Member
Level: 17


Posts: 26/56
EXP: 22289
For next: 2454

Since: 12-28-09
From: Denmark

Since last post: 7.0 years
Last activity: 6.0 years

Posted on 03-12-10 06:44:33 PM Link | Quote
More black screen.

I have made a W1 castle and it works perfect in DESmuME 0.9. However on my DSi it goes black.

- There is no sprite zero (I have used the sprite finder/count).
- There is no sprite set selected with unused sprites.
- There are no bosses except for bowser in the unchanged area3.
- The background/tileset has not been changed.

I do use a lot of objects and sprites by not more then on other levels.


Any other issues I should look at?

gridatttack

Buzzy Beetle
Rarity FTW
Level: 39


Posts: 227/375
EXP: 394616
For next: 10155

Since: 08-26-09


Since last post: 258 days
Last activity: 28 days

Posted on 03-12-10 07:04:17 PM Link | Quote
Originally posted by frjd
More black screen.

I have made a W1 castle and it works perfect in DESmuME 0.9. However on my DSi it goes black.

- There is no sprite zero (I have used the sprite finder/count).
- There is no sprite set selected with unused sprites.
- There are no bosses except for bowser in the unchanged area3.
- The background/tileset has not been changed.

I do use a lot of objects and sprites by not more then on other levels.


Any other issues I should look at?



Maybe a sprite data? I one time made the warp to level without sound and worked fine in the emulator; but on the ds, it crashed the level.
mariofanatic64
Member
Level: 23


Posts: 24/111
EXP: 61800
For next: 5923

Since: 02-03-10
From: Australia

Since last post: 3.0 years
Last activity: 2.0 years

Posted on 03-13-10 02:29:49 AM Link | Quote
is it possible to edit the tileset in the title screen? if so, will it involve tile molester?
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 473/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 03-13-10 09:18:30 AM Link | Quote
The tileset...

It doesnt work as a normal tileset, so it will probably need tile molester. It is a trio of ncg/ncl/nsc files, like the backgrounds.
Ehm
Member
Level: 46


Posts: 217/532
EXP: 675099
For next: 36675

Since: 06-13-09
From: Canada

Since last post: 120 days
Last activity: 77 days

Posted on 03-13-10 10:16:15 PM (last edited by m64m at 03-14-10 03:41 PM) Link | Quote
yeah. You need Tile Molester. Also, it'll be jumbled, so it's best to copy it into an image editor, such as MSPaint, rearrange the picture (while keeping track of the partitions, and where they go), redesign your logo, and then re-edit each partition, according to the original jumble.

EDIT:

Question: Treeki advised in a previous post not to exceed a certain width and height for level views. Is this because it will be more prone to crashes? Also, what if I did multiple views while utilizing all the space in an area? Would it be the same risk?
sjasogun1
Random nobody
Level: 4


Posts: 2/2
EXP: 148
For next: 131

Since: 03-11-10


Since last post: 7.0 years
Last activity: 7.0 years

Posted on 03-15-10 01:43:06 PM Link | Quote
Thanks for the SHIFT and the red sprite tip. I'll have to redo the entire level now though...
angelsl
Member
Level: 12


Posts: 1/25
EXP: 6557
For next: 1364

Since: 03-15-10


Since last post: 7.0 years
Last activity: 6.0 years

Posted on 03-15-10 11:09:01 PM (last edited by angelsl at 03-16-10 10:13 AM) Link | Quote
Hi.

I created a new object using the same Map16 tile as object 44 (brick).

I then set the behaviour = 00 00 02 00, and control byte 3; and then placed it world 1-1.

The game refuses to scroll to the section with my custom object (i.e it scrolls up to just a few tiles before it, and then acts as if it reached the end of map)

EDIT: Does not work with DeSmuME either


Spoiler:






Also, another question - is SVN head safe to use?

dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 483/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 03-16-10 11:33:33 AM Link | Quote
Yeah, SVN head is safe. It just has some more unfinished features, but the rest of the editor is stable.

For your block, i don't know what's going on. I see you used one of the first tiles in the Map16. I'm not sure if those are safe to use (i think they have special hard-coded behaviors or such). Why don't you try to put it more towards the bottom (for example, at those X's) ?
angelsl
Member
Level: 12


Posts: 4/25
EXP: 6557
For next: 1364

Since: 03-15-10


Since last post: 7.0 years
Last activity: 6.0 years

Posted on 03-16-10 11:42:06 AM Link | Quote
Originally posted by dirbaio
Yeah, SVN head is safe. It just has some more unfinished features, but the rest of the editor is stable.

For your block, i don't know what's going on. I see you used one of the first tiles in the Map16. I'm not sure if those are safe to use (i think they have special hard-coded behaviors or such). Why don't you try to put it more towards the bottom (for example, at those X's) ?


Some of those Xs have behaviours already, so I didn't dare edit them.

But thanks, I'll try that.
angelsl
Member
Level: 12


Posts: 5/25
EXP: 6557
For next: 1364

Since: 03-15-10


Since last post: 7.0 years
Last activity: 6.0 years

Posted on 03-17-10 03:37:22 AM (last edited by angelsl at 03-17-10 04:29 AM) Link | Quote
New problem;

using sprite 187 (Manual Control Platform) (the one with arrows, and moves in that direction you stand on), when I hit where those gridlines (in the editor) are in game, it stops scrolling.

Help? (It works normally if I walk!)

EDIT: Nevermind. For those that have the same problem, make sure the adjacent grid-square has something in it (like a brick or something.) http://jul.rustedlogic.net/thread.php?pid=148932#148932
galladeslicer

Level: 7


Posts: 3/8
EXP: 1187
For next: 261

Since: 03-14-10


Since last post: 7.0 years
Last activity: 7.0 years

Posted on 03-18-10 03:43:57 PM Link | Quote
PROBLEM!
Black screen!
The pipe is set up right like this and im able to enter it.

Click to enlarge!

I dont know what the problem is the veiws are set right and the connection is right(I think)
Here is the connection

Top image:

Green pipe top 1:
Entrance ID: 03
Des. Area: 03
Des Entrance: 00
Conn. Pipe ID: 00
View: 00

Green pipe top 2:
Entrance ID: 04
Des. Area: 03
Des Entrance: 00
Conn. Pipe ID: 00
View: 00


Yellow Pipe (Exit from Bonus)
Entrance ID: 02
Des. Area: 00
Conn. Pipe ID: 00
View: 00

[checked] Exit Only

Second Image (Bottom)

Green pipe (Exit regular area)
All "00"
[Checked] Exit only

Sideways Pipe 1:
Entrance ID: 02
Des. Area: 01
Des Entrance: 02
Conn. Pipe ID: 00
View: 00
[checked]

Sideways Pipe 1:
Entrance ID: 03
Des. Area: 01
Des Entrance: 02
Conn. Pipe ID: 00
View: 00
[checked]

Some one please help!
mariofanatic64
Member
Level: 23


Posts: 29/111
EXP: 61800
For next: 5923

Since: 02-03-10
From: Australia

Since last post: 3.0 years
Last activity: 2.0 years

Posted on 03-18-10 07:59:41 PM Link | Quote
i have trouble with editing ? and Brick Blocks from the Jyotu tileset. Is there a tutorial on how to do it?
Ehm
Member
Level: 46


Posts: 228/532
EXP: 675099
For next: 36675

Since: 06-13-09
From: Canada

Since last post: 120 days
Last activity: 77 days

Posted on 03-18-10 09:24:12 PM Link | Quote
@ mariofanatic64 - for these particular objects, since they're animated, you need to LZ Decompress the Jyoutu files, export them, and open them in Tile Molester. I never did that, however. Jceggbert5 animated my '?' block design for me, so he'd be better to talk to about this.
mariofanatic64
Member
Level: 23


Posts: 30/111
EXP: 61800
For next: 5923

Since: 02-03-10
From: Australia

Since last post: 3.0 years
Last activity: 2.0 years

Posted on 03-18-10 10:17:25 PM Link | Quote
ok thanks
angelsl
Member
Level: 12


Posts: 9/25
EXP: 6557
For next: 1364

Since: 03-15-10


Since last post: 7.0 years
Last activity: 6.0 years

Posted on 03-20-10 07:34:13 AM Link | Quote
Two questions.

1. I think I read somewhere that the world 8-FC 'up, down, middle' quiz is hardcoded into the game; is this correct?
2. Is is possible to have levels flipping over like in world 8-FC? (using a ? switch, activates some funny activator ID)
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 501/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 03-20-10 08:05:35 AM Link | Quote
Try looking at how it is made, and replicate it on your level...
Views are organized in pairs. one is normal and the other is upside-down. One of them has one special byte set i think. Probably you have to be in the center of the view, and hit that switch, which will make the rotating effect, and will teleport you to the other corresponding view, so it looks like everything is rotated.

For the castle loops... I'm not sure. There are some sprites, so it's not completely hard-coded. You could try looking at their data and figuring it out.
frjd
Member
Level: 17


Posts: 34/56
EXP: 22289
For next: 2454

Since: 12-28-09
From: Denmark

Since last post: 7.0 years
Last activity: 6.0 years

Posted on 03-20-10 09:22:09 AM Link | Quote
Originally posted by galladeslicer
PROBLEM! Black screen!


Is it W1-4? and a (E) ROM?
If I even more one block in W1-4 Area 2 or 3 I get black screen when I return.

Also W2-1 area 3 have given me trouble. Had to import a clean original level to make it work.

Remember only if you need a different tileset you need the other areas. If you can use same tileset just use more views insted.



angelsl
Member
Level: 12


Posts: 10/25
EXP: 6557
For next: 1364

Since: 03-15-10


Since last post: 7.0 years
Last activity: 6.0 years

Posted on 03-20-10 11:07:22 PM (last edited by angelsl at 03-20-10 11:10 PM) Link | Quote
Originally posted by dirbaio
Try looking at how it is made, and replicate it on your level...
Views are organized in pairs. one is normal and the other is upside-down. One of them has one special byte set i think. Probably you have to be in the center of the view, and hit that switch, which will make the rotating effect, and will teleport you to the other corresponding view, so it looks like everything is rotated.

For the castle loops... I'm not sure. There are some sprites, so it's not completely hard-coded. You could try looking at their data and figuring it out.


I wanted to try that.. but

the activator ID is like 35/36/37, and I don't know what has that activator ID, or how to calculate that activator ID, or if the activator ID is in another block (data block, not object or sprite), etc

Lemme try it anyway.
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 502/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 03-21-10 05:22:39 AM Link | Quote
Hmmm...

Some activator ID's may have hard-coded effects. I saw somewhere a hard-coded activator number would make the blue coins effect seen in world 7-sth, without other sprites than the ?-switch

Maybe 36 rotates between views 0-1, 37 between 2-3, etc...
angelsl
Member
Level: 12


Posts: 11/25
EXP: 6557
For next: 1364

Since: 03-15-10


Since last post: 7.0 years
Last activity: 6.0 years

Posted on 03-21-10 10:55:29 AM Link | Quote
Originally posted by dirbaio
Hmmm...

Some activator ID's may have hard-coded effects. I saw somewhere a hard-coded activator number would make the blue coins effect seen in world 7-sth, without other sprites than the ?-switch

Maybe 36 rotates between views 0-1, 37 between 2-3, etc...


The flipped side of the view has no view assigned to it (it's outside of any view)
Pages: 1 2 3 4 5 6 7 8 9 10 ... 56 57 58 59 60 61 62 63 64 65Next newer thread | Next older thread
Jul - NSMB Hacking (Archive) - Help/Questions thread. ASK QUESTIONS HERE! New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 2f1bc75 [2017-08-27]
©2000-2017 Acmlm, Xkeeper, Inuyasha, et al.

32 database queries, 9 query cache hits.
Query execution time: 0.222008 seconds
Script execution time: 0.015147 seconds
Total render time: 0.237155 seconds