Register - Login
Views: 95157389
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - Stats - Latest Posts - Color Chart - Smilies
09-20-18 04:36:20 AM

Jul - SM64 Hacking (Archive) - Mario 64 Level Importer New poll - New thread - New reply
Pages: 1 2 3 4 5 6 7 8 9 10 ... 45 46 47 48 49 50 51 52 53 54 55Next newer thread | Next older thread
DarkSpacer
Member
Level: 29


Posts: 111/184
EXP: 139020
For next: 8865

Since: 03-23-10


Since last post: 2.0 years
Last activity: 1.0 years

Posted on 09-14-11 03:55:58 PM Link | Quote
Maybe. I really hope to have Area mod support, it'll make it eisier to find levels that have Area 3 enabled so I could test Eyerock...I haven't been doing anything with him because I'm trying to figure out how to make him do ANYTHING. If he's included in the object bank he should work, right? He can't just not appear...the game should at least crash...
Lyskar
12210
-The Chaos within trumps the Chaos without-
Level: 185


Posts: 10187/12211
EXP: 86368387
For next: 1391348

Since: 07-03-07

From: 52-2-88-7

Since last post: 3.0 years
Last activity: 3.0 years

Posted on 09-14-11 04:11:46 PM Link | Quote
These utilities are not a silver bullet, so if you add something and it doesn't work, that doesn't mean the utility writer must come to your rescue.

As for changing other things than just levels, that's up to Messaien. He's doing this for free and all---it'd be rude to just keep asking him to do more and more and more. He has a life, you know.
DarkSpacer
Member
Level: 29


Posts: 112/184
EXP: 139020
For next: 8865

Since: 03-23-10


Since last post: 2.0 years
Last activity: 1.0 years

Posted on 09-14-11 08:24:41 PM Link | Quote
I know that. I wasn't trying to be pushy like...some...people here. Just it's hard to hack when you're stuck...everyone else just posts randomly, I'm actually trying to be smart and having a hard time of it...
Ello
User
Level: 12


Posts: 8/24
EXP: 6452
For next: 1469

Since: 06-22-10

From: Augsburg, Germany

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 09-15-11 07:22:08 PM (last edited by Ello at 09-15-11 07:24 PM) Link | Quote
Hey people

Im working with toadstool 64 and the objLevelimporter for about two months now. Found out a lot of stuff and imported a lot of obj files to my ROM. I use google sketchup to create my .objs and the importer by messiean. Everything was fine till today, when i wanted to replayce "Secret Aquarium" with a random obj, just to test something. Since i have done that, i cant open that ROM anymore in TT64, cause i get:

Director Player Error
List expected for handler

#count
Script Error. Continue?

When I click on "Yes"
i get the next one

Object expected

Script Error. Coninue?

Sometimes i can see some of the put objects in toadstool for a few seconds, but then the screen f TT64 becomes black. cant edit anymore since today..
But I did the same as I did the last two months. When i choose another ROM, it works fine. No Errors, everything is loaded. There was a post in 2009 I think, where peole had a similar problem, but i couldnt find a solution there, it was just said, this will be fixed in 0.59, yeah... i have 0.5994b and i have no clou anymore.

Please help me, some others on the internet seem to have the same probem, but i cant find a solution that works and I want to go on editing...

Thanks for your help

[Edit] Maybe that is a question for the TT64 thread, but im not sure which program produces the Error, so i wrote it in here. Add to this i asked a question in the TT64 thread and havent got an answer for about three weeks now...
DarkSpacer
Member
Level: 29


Posts: 113/184
EXP: 139020
For next: 8865

Since: 03-23-10


Since last post: 2.0 years
Last activity: 1.0 years

Posted on 09-15-11 07:54:36 PM Link | Quote
Originally posted by Ello
i asked a question in the TT64 thread and havent got an answer for about three weeks now...


Oh good god...

Let's see...

Seems you did everything fine, but your last object broke it...hmm...well you said "test", so you can expect errors, but...so...*looks warily at Metal Man's Ban Hammer*...er, yeah. Try something else then...
Ello
User
Level: 12


Posts: 9/24
EXP: 6452
For next: 1469

Since: 06-22-10

From: Augsburg, Germany

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 09-15-11 08:15:31 PM Link | Quote
Thanks for the answer, the thing is this is my only ROM, where I put all the objects in the right way. Every coin is at his right position, same is with all the enemies in the first course. I would appreciate it if i did not have to placeall the objects with TT64 in my two leves again... At the moment I cant change any object with this ROM and I dont have a copy either.
Is there any way to repair this ROM or fix this Error?
Lyskar
12210
-The Chaos within trumps the Chaos without-
Level: 185


Posts: 10198/12211
EXP: 86368387
For next: 1391348

Since: 07-03-07

From: 52-2-88-7

Since last post: 3.0 years
Last activity: 3.0 years

Posted on 09-15-11 08:52:13 PM Link | Quote
That question belongs in the TT64 question thread. Do not pollute this thread with it.

And you, Darkspacer, need to stop trying to frighten people of my "ban hammer." That's just backseat moderating.

Any further unrelated questions or replies will be deleted from this topic.
messiaen
Catgirl
Level: 65


Posts: 1032/1085
EXP: 2248041
For next: 87587

Since: 11-20-07


Since last post: 4.0 years
Last activity: 3.0 years

Posted on 09-19-11 10:40:53 AM (last edited by messiaen at 09-19-11 10:43 AM) Link | Quote
Here's the new release (v16) of the importer with the 3D preview: Download.

Changes:

- 3D preview feature.
- Set level Y rotation (try 90, 180 and 270 and see how the camera reacts).
- Option to override normal polygon limitations (6500) for people who want to test (not sure they'll work) even bigger levels.
- Cheapo texture brightness setting
- Fixed pause menu warp bug

Please report any bugs/issues.
Ello
User
Level: 12


Posts: 14/24
EXP: 6452
For next: 1469

Since: 06-22-10

From: Augsburg, Germany

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 09-21-11 09:13:30 PM (last edited by Metal_Man88 at 09-22-11 09:13 PM) Link | Quote
Hey

Im working with the new Levelimporter,
and I dont get this thing with the Trajectory file for moving platforms completely.
Here what what I want to achieve:
A patroling, hexagonal platform which moves, without standing on it. So you have to jump on it when it passes.

My problems:

In the collumn, where i can choose the kind of Trajectory, I find te parameter "platform on track" but not "Path" , wich is the parameter of my hexagonal moving mesh from Lethal Lava Land in the 0x0E Object bank. Is there a way to write an own track for those meshes or can I only write some for "Platform on tracks"? I thought it would work for all moving platforms.

I also tried to write a track for "platform on tracks", but when i tested it with "Cage on track", the game froze everytime. But its not an undefined combo, this is its supposed behaviour. Or did I make a mistake?


@messean: the last part could be a bug in the level importer. Would be nice if that worked.

thanks so far

The rotation around the Y-axis doesnt work for me. At least the Coordinates of Mario Start doesnt change and the Environment is still at the same place.. A rotated from 90 over 180 to 270°. No changes.

Ello
Cajetan
Member
Level: 20


Posts: 7/86
EXP: 40678
For next: 1761

Since: 08-06-11

From: Binary

Since last post: 3.0 years
Last activity: 1.0 years

Posted on 09-24-11 06:47:29 AM (last edited by Cajetan at 09-24-11 06:47 AM) Link | Quote
Originally posted by messiaen
Here's the new release (v16) of the importer with the 3D preview: Download.

Changes:

- 3D preview feature.
- Set level Y rotation (try 90, 180 and 270 and see how the camera reacts).
- Option to override normal polygon limitations (6500) for people who want to test (not sure they'll work) even bigger levels.
- Cheapo texture brightness setting
- Fixed pause menu warp bug

Please report any bugs/issues.



A Question, how can i zoom to my Model? It would be great if i could do that.
Ello
User
Level: 12


Posts: 16/24
EXP: 6452
For next: 1469

Since: 06-22-10

From: Augsburg, Germany

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 09-25-11 12:09:52 PM (last edited by Ello at 09-25-11 06:26 PM) Link | Quote
I would suggest to use ToadsTool 64 for that. No idea how/if that works is the levelimporter.

Does anyone know what way the chain chomp takes, when he's affranchised? Im testing but i dnt get the rules/parameters/algorithms where he flees. But i have no clue yet..
DarkSpacer
Member
Level: 29


Posts: 114/184
EXP: 139020
For next: 8865

Since: 03-23-10


Since last post: 2.0 years
Last activity: 1.0 years

Posted on 09-25-11 09:29:32 PM (last edited by DarkSpacer at 09-26-11 03:42 PM) Link | Quote
The Chain Chomp, when he's first freed, stays in place for a while (a little longer than the "Secret Found" sound), then he starts jumping around at random (but he stays inside a fairly small area), then, after five collisions with the ground, he jumps toward the gate with the star in it (or whatever the Chain Chomp recognizes as a gate, if you want to be precise), then he jumps back, then jumps to a point behind the cave (or whatever it's called). I think he jumps toward a specific XYZ coordinate and not to an object. I haven't located the object where he jumps to, although it might be an object that's also used for something else.

In pseudo-code:

If freed()
then
RandomJump(25,5,7) //(JumpRadius,JumpCount,JumpSpeed)
Jump(GateObj,7) // (Obj,JumpSpeed)
JumpToPoint(X,Y,Z) // Placeholders...
JumpToPoint(X,Y,Z) [[OR]] Jump(ChainJump,7) // Placeholders
EndIf

All numbers are just for show...

EDIT: OH GOD I did not realize the size of my mood avatar. ...Will fix later. Dinner bell JUST rang :p

EDIT 2: Fixed. They seemed to have disabled display of it so I'll just do a cheap thing

E 3: ...and it failed. Great.
Ello
User
Level: 12


Posts: 17/24
EXP: 6452
For next: 1469

Since: 06-22-10

From: Augsburg, Germany

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 09-26-11 10:00:50 AM (last edited by Ello at 09-26-11 11:35 AM) Link | Quote
that seems to be logical.. but where cod i find that code? I dont have any tool to open the code...
And i cant find anything to change hose parameters in the leve importer. I tried some preferences about the chain chomp in the collision column of the importer, but that didnt work. The chomp fled to the sky and didnt destroy anything.

Any other ideas?

@messiean: I get scaling errors (out of bounds) when I change the model offset position. Is that right or a bug?
DarkSpacer
Member
Level: 29


Posts: 115/184
EXP: 139020
For next: 8865

Since: 03-23-10


Since last post: 2.0 years
Last activity: 1.0 years

Posted on 09-26-11 03:54:33 PM (last edited by DarkSpacer at 09-26-11 03:55 PM) Link | Quote
It's interesting that he fled to the sky...the default point must be really high up...wait what did you do anyway?

If you're insistent about this and you really do know how to get into the rom, look for where the chain chomp is loaded and trace the Model/Behavior ID and see what it does.

[I cropped all my mood avatars to be a lot smaller, so there SHOULD be no problems. If there are, please tell me.]

EDIT: Except they've disabled ALL mood avatars. Oh well...
Ello
User
Level: 12


Posts: 18/24
EXP: 6452
For next: 1469

Since: 06-22-10

From: Augsburg, Germany

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 09-29-11 08:48:07 AM Link | Quote
Which Tool do you use to open the code and read it/change it?

I tried to create a checkboard Elevator, which moves on a track. But the feature of the level-importer, which appoints the track doesnt work... I wrote a .txt with coordinates, and save it as a trajectory. I chose "Platform on track 2. Param 08" for example and entered the same parameter into the elevator in Toads Tool. But when i started the game the elevator wasnt there. It was not displayed at all.
Does anyone have gained experiences about that problem?
dsx9069
Member
Level: 13


Posts: 29/30
EXP: 8465
For next: 1802

Since: 06-14-11

From: NY, USA

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 10-03-11 10:56:34 PM (last edited by dsx9069 at 10-03-11 11:55 PM) Link | Quote
Cheers to Messiaen for his Mario 64 Level Importer v16. It seems to have a Trojan on it, though, according to my Avira Antivirus. Should I ignore this, or is there another source aside from Google Documents where I could download the Importer?

EDIT: I extracted the download, and my anti-virus detected a Trojan on "objimport.exe", which wasn't the main executable named "ObjImportGUI.exe". It would seem that someone is tampering with your m64 level importer archive.
Lyskar
12210
-The Chaos within trumps the Chaos without-
Level: 185


Posts: 10300/12211
EXP: 86368387
For next: 1391348

Since: 07-03-07

From: 52-2-88-7

Since last post: 3.0 years
Last activity: 3.0 years

Posted on 10-03-11 11:53:14 PM Link | Quote
Generally antivirus software misinterprets what these things are. I'd ignore it if I were you.
dsx9069
Member
Level: 13


Posts: 30/30
EXP: 8465
For next: 1802

Since: 06-14-11

From: NY, USA

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 10-04-11 12:34:52 AM (last edited by dsx9069 at 10-04-11 12:38 AM) Link | Quote
Originally posted by Ello
Which Tool do you use to open the code and read it/change it?

I tried to create a checkboard Elevator, which moves on a track. But the feature of the level-importer, which appoints the track doesnt work... I wrote a .txt with coordinates, and save it as a trajectory. I chose "Platform on track 2. Param 08" for example and entered the same parameter into the elevator in Toads Tool. But when i started the game the elevator wasnt there. It was not displayed at all.
Does anyone have gained experiences about that problem?


I've tried using the checkerboard model a few times before in the past, and the only solution I found thus far is to use the flying carpet in the Rainbow Ride level as the model (with the "platform on tracks" behavior). However, this would mean that your third object bank for the level would have to be "Rainbow Ride"...

...Unless someone else has had better luck working with the checkerboard elevator model. Ello, did the game freeze when you approached the area where the checkerboard elevator was supposed to be?
Cajetan
Member
Level: 20


Posts: 8/86
EXP: 40678
For next: 1761

Since: 08-06-11

From: Binary

Since last post: 3.0 years
Last activity: 1.0 years

Posted on 10-04-11 04:20:10 AM (last edited by Cajetan at 10-04-11 04:34 AM) Link | Quote
I found a bug!

I pressed Preview Level, everything opens normal. Now i wanted to set my Scale for my Level. I did set it to 300.0 which fits right. I pressed Quit and save Changes. Then i imported my level but still get the error that my vertexes were out of bounds... I looked at Preview again and then... WTF? My Model was set to 30000 Scale? How did this happen? I tried the same again and the same happens once again. Is this some bug or am i doing something false?

Here a proof Picture:




EDIT: But with some cleverness and intelligence you could easily just write 3.00 and it will show 300.00 that what i wanted, but still that bug should be fixed. I also resized my Picture, so Metal doesn't have to do much work
Lyskar
12210
-The Chaos within trumps the Chaos without-
Level: 185


Posts: 10301/12211
EXP: 86368387
For next: 1391348

Since: 07-03-07

From: 52-2-88-7

Since last post: 3.0 years
Last activity: 3.0 years

Posted on 10-04-11 04:28:46 AM Link | Quote
That is intriguing. We'll see what Messiaen says.
Pages: 1 2 3 4 5 6 7 8 9 10 ... 45 46 47 48 49 50 51 52 53 54 55Next newer thread | Next older thread
Jul - SM64 Hacking (Archive) - Mario 64 Level Importer New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 5d36857 [2018-03-03]
©2000-2018 Acmlm, Xkeeper, Inuyasha, et al.

30 database queries, 11 query cache hits.
Query execution time: 0.263956 seconds
Script execution time: 0.031786 seconds
Total render time: 0.295742 seconds
Memory used: 1310720