Register - Login
Views: 85653163
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - JCS - Stats - Latest Posts - Color Chart - Smilies
09-22-17 05:53:44 PM

Jul - SM64 Hacking - Mario 64 Level Importer New poll - New thread - New reply
Pages: 1 2 3 4 5 6 7 8 9 10 ... 43 44 45 46 47 48 49 50 51 52 53 54 55Next newer thread | Next older thread
JPaul

Level: 6


Posts: 7/7
EXP: 880
For next: 27

Since: 07-18-11


Since last post: 6.0 years
Last activity: 6.0 years

Posted on 07-24-11 07:16:50 PM Link | Quote
Working on the hub/stage selection area of my mod. It's Mario's neighborhood. I wanna make Mario's house enterable, but the importer doesn't support sub-areas...
supermario3459
Random nobody
Level: 6


Posts: 1/6
EXP: 699
For next: 208

Since: 07-14-11


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 07-25-11 04:35:15 PM (last edited by supermario3459 at 07-25-11 04:40 PM) Link | Quote
Hi,

i have started a hack and completed the first level, made it in google sketchup, used obj importer and added objects with toad's tool, but when i entered the level to test it, this happened :



This is the unfamous white screen crash, look at the FPS when i used max speed on emulator as a proof of the crash, the level worked fine before i edited with toad's tool, once this glitch happened i deleted all object from toad's tool but its still here.

what is the nature of the problem, item overuse ? wrong warp location ? or just a bad luck ?

please help me, thanks !
DarkSpacer
Member
Level: 28


Posts: 103/184
EXP: 130648
For next: 690

Since: 03-23-10


Since last post: 1.0 years
Last activity: 156 days

Posted on 08-01-11 03:04:51 PM Link | Quote
Looks to be stuck in an infinite loop judging by the Idle reading...

Did you put in any weird objects? Because some objects that need extra data or are just complicated USUALLY make the game access blank/useless data if they're not defined correctly (BOB King in SSL, Eyerok in Area 1 (or something), etc).

Technically you could put the BOB King in SSL if you manage to extract SSL and set cameras and---*shot*

You know. Make sure you're object banks are set correctly and make sure you know what you're doing...



RANDOM THOUGHT:
I wonder if anyone has ever tried to code an NPC Mario...that'll be interesting...
MinyaKang
User
Level: 9


Posts: 5/13
EXP: 2307
For next: 855

Since: 02-03-11


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 08-23-11 07:51:10 PM (last edited by MinyaKang at 08-23-11 09:03 PM) Link | Quote
Huh, did this thread die? If it didn't, could anyone help with a problem with Bob Bomb King? I put at Act 1, loaded him and everything, and he works and you can fight him, but he makes everything sound Glitchy, and the normal level song can't play at all in any act before or after his fight. Help PLEASE!
DarkSpacer
Member
Level: 28


Posts: 105/184
EXP: 130648
For next: 690

Since: 03-23-10


Since last post: 1.0 years
Last activity: 156 days

Posted on 08-24-11 02:51:40 PM (last edited by Metal_Man88 at 08-25-11 09:19 PM) Link | Quote
Actually I thought it did die but now it's ALIVE! MUAHAHA--um.

I really need more information before I can tell you anything.

I'll try to reproduce your error if I'm up to it, but it may have something to do with the collision you used...there's some ground collision used specifically for the King in the level...did you use that?
MinyaKang
User
Level: 9


Posts: 6/13
EXP: 2307
For next: 855

Since: 02-03-11


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 08-24-11 05:58:16 PM (last edited by MinyaKang at 08-25-11 04:53 PM) Link | Quote
We're keeping it alive, and we have no idea how to fix problems... Also, Which friggin collison would it be?
DarkSpacer
Member
Level: 28


Posts: 106/184
EXP: 130648
For next: 690

Since: 03-23-10


Since last post: 1.0 years
Last activity: 156 days

Posted on 08-25-11 09:12:55 PM (last edited by Metal_Man88 at 08-25-11 09:18 PM) Link | Quote
In Messain's importer it's called "65: Top of Bomb-Omb Battlefield mountain wide angle"

And we know how to fix problems. It's just that some of the recent problems have been reeealllly odd.
MinyaKang
User
Level: 9


Posts: 7/13
EXP: 2307
For next: 855

Since: 02-03-11


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 08-26-11 01:18:06 AM Link | Quote
Ahh, thank you. Also, Would I put the same for King Whomp?
DarkSpacer
Member
Level: 28


Posts: 107/184
EXP: 130648
For next: 690

Since: 03-23-10


Since last post: 1.0 years
Last activity: 156 days

Posted on 08-26-11 02:46:33 PM (last edited by DarkSpacer at 08-26-11 02:55 PM) Link | Quote
I'm not entirely sure what collision that uses. But it's not the same collision, because when the tower appears after the first star the camera no longer goes wide-angle. And in BOB the camera stays wide-angle when the Koopa Flag appears.

Actually I'm not sure if the camera is trying to follow the flag or not...I think it is...I'll test that.


And any way to remove Mario's giant fat nose? For my Sonic hack I can't get the mouth to look right because of the nose...



EDIT: In case anyone is wondering, I'm using Dropbox for my images.
MinyaKang
User
Level: 9


Posts: 8/13
EXP: 2307
For next: 855

Since: 02-03-11


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 08-26-11 06:06:33 PM Link | Quote
Umm, I have no idea how to change mario's nose sadly. Only a few people really know how to hack mario's model, sorry.
Lyskar
12210
-The Chaos within trumps the Chaos without-
Level: 182


Posts: 10072/12211
EXP: 82459500
For next: 445135

Since: 07-03-07
From: 52-2-88-7

Since last post: 2.0 years
Last activity: 2.0 years

Posted on 08-26-11 06:21:10 PM Link | Quote
Mario's model requires manual modification of some complex data. You're unlikely to get anywhere unless you really know what you're doing.

Just PM/ask Dudaw. He'll tell you.
MinyaKang
User
Level: 9


Posts: 9/13
EXP: 2307
For next: 855

Since: 02-03-11


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 08-26-11 08:27:11 PM (last edited by MinyaKang at 08-26-11 10:19 PM) Link | Quote
yeah, what he said.

Also, I'm having trouble with a stage. I Imported a desert stage I made and it has three Deserty Textures, where one of them has the normal sand effect: , another has the Quicksand Death effect: , and the last is normal: . It says its imported just fine and when I try to look at the stage in Toads Tool, it says near the end of loading the stage:



The stage looks like this:



Some please help me!

It go's over Whomp's Fortress, and was made with Google Sketchup.
Eggs6131
Member
Level: 19


Posts: 1/82
EXP: 34974
For next: 803

Since: 08-27-11
From: United Kingdom

Since last post: 3.0 years
Last activity: 2.0 years

Posted on 08-27-11 06:38:39 AM (last edited by Eggs6131 at 06-24-12 10:55:57 AM) Link | Quote
Hello, thought I'd show my face here.

I'm having a little bit of trouble with the level importer. This is part of a (now unused) hub I'm making for my hack. Here's what it looks like on Sketchup:




And this is what it looks like in-game:




As you can see, the textures are completely wrong, and most confusingly, the stage is the wrong way round!

I can't get the waterbox below the level it is in the picture, whatever height number I enter. The bridge is littered with invisible walls and I can walk through the house!

So, yeah, if anyone knows how to fix these problems I'd be very grateful
messiaen
Catgirl
Level: 64


Posts: 1025/1085
EXP: 2142601
For next: 71496

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 08-27-11 11:39:38 AM Link | Quote
Originally posted by Eggs6131
The stage is the wrong way round!

For now, you must swap the axis (rotate X90 I think) on SketchUp, next version of the importer (no idea when it comes out, but I may try to work a bit on it in september) will have a function to fix it .

Also, have you tried negative water height? Ii goes down do -8192.
Cajetan
Member
Level: 20


Posts: 4/86
EXP: 37738
For next: 4701

Since: 08-06-11
From: Binary

Since last post: 2.0 years
Last activity: 333 days

Posted on 08-27-11 12:35:38 PM Link | Quote
Originally posted by messiaen
Originally posted by Eggs6131
The stage is the wrong way round!

For now, you must swap the axis (rotate X90 I think) on SketchUp, next version of the importer (no idea when it comes out, but I may try to work a bit on it in september) will have a function to fix it .

Also, have you tried negative water height? Ii goes down do -8192.


I expected you gave up, hacking SM64?

Also, this helps much.
DarkSpacer
Member
Level: 28


Posts: 108/184
EXP: 130648
For next: 690

Since: 03-23-10


Since last post: 1.0 years
Last activity: 156 days

Posted on 08-27-11 03:14:54 PM Link | Quote
Eggs6131 (green eggs and ham?):

You are undoubtedly using an older version of the importer. Download the latest version from Messain's website.

Unless you're trying to texture both sides of every polygon...even if you use the "guess" feature of the importer, you're going to have problems...

And the wrong textures are caused by a mistype. To fix this, go into the importer file itself (C:\Program Files\Google\Google SketchUp x\Plugins\ObjExporter.rb) and open it with Notepad (right click, "Open With..." and choose Notepad), then find and replace all instances of "mapKd" with "map_Kd".

Correct me if I'm wrong...
messiaen
Catgirl
Level: 64


Posts: 1026/1085
EXP: 2142601
For next: 71496

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 08-27-11 05:44:22 PM Link | Quote
I don't have time anymore to work on SM64 and I'm a bit fed up of it, but I might release what I already have since people are starting to release their full hacks (such as Mario 74 and Star Road). Also, it would be nice it someone could keep the "List of released SM64" hacks updated and stickied for reference.

Dunno about the mapKd issue, but I think the last version of the importer already fixed this. Also, some people have been reporting that using the native .OBJ Exporter of Google SketchUp Pro yields much better results on texture mapping and collision than this free plug-in.
DarkSpacer
Member
Level: 28


Posts: 109/184
EXP: 130648
For next: 690

Since: 03-23-10


Since last post: 1.0 years
Last activity: 156 days

Posted on 08-27-11 06:36:45 PM Link | Quote
Yields better results on COLLISION??

I'm...there's something messy that the plugin does I bet. Who wrote that thing anyway?

The plugin's worked fine for me so far. If push comes to shove though, I'll buy GS Pro and see if that helps.

*tries to rant about collision vs. polygons and utterly fails*
MinyaKang
User
Level: 9


Posts: 10/13
EXP: 2307
For next: 855

Since: 02-03-11


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 08-28-11 02:49:10 AM Link | Quote
Okay, how come if I Go into Whomps Fortress and die, I come out of Bob-ombs battlefield picture frame. I have custom levels over both of them. How do I stop this madness?
Eggs6131
Member
Level: 19


Posts: 2/82
EXP: 34974
For next: 803

Since: 08-27-11
From: United Kingdom

Since last post: 3.0 years
Last activity: 2.0 years

Posted on 08-28-11 04:36:48 AM Link | Quote
DarkSpacer, I am using the latest version of the importer (v15) and no, I am not trying to texture both sides of the polygon. But I'll try your instructions, thank you.

And MinyaKang, you haven't set a proper death warp. You must do this in Toad's Tool.
Pages: 1 2 3 4 5 6 7 8 9 10 ... 43 44 45 46 47 48 49 50 51 52 53 54 55Next newer thread | Next older thread
Jul - SM64 Hacking - Mario 64 Level Importer New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 2f1bc75 [2017-08-27]
©2000-2017 Acmlm, Xkeeper, Inuyasha, et al.

31 database queries, 12 query cache hits.
Query execution time: 0.200176 seconds
Script execution time: 0.015846 seconds
Total render time: 0.216022 seconds