Register - Login
Views: 86587754
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - JCS - Stats - Latest Posts - Color Chart - Smilies
10-22-17 07:05:24 AM

Jul - NSMB Hacking (Archive) - Editor Development thread New poll - New thread - New reply
Pages: 1 2 3 4 5 6 7 8 9 10 ... 25 26 27 28 29 30 31 32 33 34Next newer thread | Next older thread
playerbas5

Level: 23


Posts: 34/112
EXP: 58892
For next: 8831

Since: 01-18-11
From: The Netherlands

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 01-23-11 01:53:29 PM Link | Quote
There's a bug in 5.2:

The index is outside the array bounds.

I dont know what that means, but i edited w1-3.
I made the vieuw bigger.
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 193/467
EXP: 527573
For next: 37473

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 01-23-11 01:58:34 PM Link | Quote
Originally posted by playerbas5
There's a bug in 5.2:

The index is outside the array bounds.

I dont know what that means, but i edited w1-3.
I made the vieuw bigger.

This is a already known bug.
I have already told dirbaio about this fuckin ROM lock^^
Dont worry, you can still open the ROM with 5.1
playerbas5

Level: 23


Posts: 35/112
EXP: 58892
For next: 8831

Since: 01-18-11
From: The Netherlands

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 01-23-11 02:09:41 PM Link | Quote
ok, but it is only at 1 level, i can edit all the other levels.
but i will use 5.1
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 1103/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 01-23-11 02:12:35 PM Link | Quote
Originally posted by NsmB_PrO

I have already told dirbaio about this fuckin ROM lock^^
Dont worry, you can still open the ROM with 5.1


I still can't reproduce it.
Can you tell me the exact steps from an unmodified rom that will cause the problem?
Something like: Open a fresh E rom, edit 1-3, make the view bigger, save, close, open again, and you get the error.

I can't fix it if I cant make it happen
ray
Member
Level: 36


Posts: 160/321
EXP: 289724
For next: 18386

Since: 11-10-10


Since last post: 6.0 years
Last activity: 3.0 years

Posted on 01-23-11 02:15:08 PM Link | Quote
Dirbaio, when i tried to edit the 3D Textures with r141 I can't get other colors. Its always grey and I cant save
And how can i add pallettes?
Can you fix it?
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 1104/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 01-23-11 02:17:34 PM Link | Quote
Originally posted by ray
Dirbaio, when i tried to edit the 3D Textures with r141 I can't get other colors. Its always grey and I cant save
And how can i add pallettes?
Can you fix it?


Man, i've barely added VIEWING support and you want to EDIT them??
I have'nt even tested to edit them.
dark_star
Member
Level: 13


Posts: 21/31
EXP: 8737
For next: 1530

Since: 10-16-10
From: France

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 01-23-11 02:24:08 PM Link | Quote
Originally posted by NsmB_PrO
Originally posted by dark_star
Could someone pass a link of last rev please?
Because I'm a real noob in computer and all this seems complicated to me ><
Or if not, could anyone make a tutorial to explain how do I do?
Thank you in advance.
PS: I use a translator

1) No, only noobs give links to compiled .exe's
---------------------------------------------------------------------------------------------
2) Download TortoiseSVN and make a checkout: "http://nsmb-editor.googlecode.com/svn/trunk"
3) Download visual studio
4) Click BUILD
5) The 5.2 is in the nsmb-editor/NSMBe4/bin/debug/NSMBe5.exe

PS: Please post questions like this in the questions thread instead

Good luck and have fun

Euh...How can we make a checkout? XD
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 1105/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 01-23-11 02:26:24 PM Link | Quote
Right click any folder and select "TortoiseSVN Checkout"
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 194/467
EXP: 527573
For next: 37473

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 01-23-11 02:32:14 PM (last edited by NsmB_PrO at 01-23-11 02:33 PM) Link | Quote
Originally posted by dirbaio
Originally posted by NsmB_PrO

I have already told dirbaio about this fuckin ROM lock^^
Dont worry, you can still open the ROM with 5.1


I still can't reproduce it.
Can you tell me the exact steps from an unmodified rom that will cause the problem?
Something like: Open a fresh E rom, edit 1-3, make the view bigger, save, close, open again, and you get the error.

I can't fix it if I cant make it happen

Since r140 the problem doesn't exist anymore...for me
But I will make notes what I have done exactly after hacking NSMB, so when the ROM crashes again, I can tell you what I have done exactly

BUG report: Can't open textures with the ending ".EGE"
dark_star
Member
Level: 13


Posts: 22/31
EXP: 8737
For next: 1530

Since: 10-16-10
From: France

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 01-23-11 02:40:18 PM Link | Quote
ok thanks ^^
And what is the version of Visual Studio I have to take?
Or is this a cracked version i have to take?
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 195/467
EXP: 527573
For next: 37473

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 01-23-11 02:46:34 PM Link | Quote
Originally posted by dark_star
ok thanks ^^
And what is the version of Visual Studio I have to take?
Or is this a cracked version i have to take?

you can take the version you want to take...
You dont need to crack visual studio (if you use 2010 express)
You just have to get a FREE windows live ID
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 1106/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 01-23-11 02:57:07 PM Link | Quote
Originally posted by NsmB_PrO

BUG report: Can't open textures with the ending ".EGE"


You mean the german ones...
Yeah, they have the same format as the normal ones. I'll do a quick fix right now
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 1107/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 01-23-11 03:02:44 PM Link | Quote
r142 out right now.

Now 3D textures can be edited and saved. Also, fixed the .EGE files.
I still have to add support for the fucking Type 5 textures. They have a headache-inducing compression format.
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 196/467
EXP: 527573
For next: 37473

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 01-23-11 03:52:13 PM Link | Quote
The palette of some textures have bugs!
I cant see the whole palette. For example: evf_spark1_b.nsbtx
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 1108/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 01-23-11 04:07:28 PM Link | Quote
Originally posted by NsmB_PrO
The palette of some textures have bugs!
I cant see the whole palette. For example: evf_spark1_b.nsbtx


Fixed!
playerbas5

Level: 23


Posts: 36/112
EXP: 58892
For next: 8831

Since: 01-18-11
From: The Netherlands

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 01-24-11 09:07:48 AM Link | Quote
If I edit the ROM and save it, nothing happens.
But after a few times, lets say 5 times, the ROM logo and text is corrupted.
Sir Cink
Member
Level: 21


Posts: 27/96
EXP: 46840
For next: 3103

Since: 01-07-11
From: The Netherlands

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 01-24-11 09:29:04 AM Link | Quote
Someone got this on mac?
Please I need it
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 197/467
EXP: 527573
For next: 37473

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 01-24-11 11:50:51 AM (last edited by NsmB_PrO at 01-24-11 11:51 AM) Link | Quote
Originally posted by Sir Cink
Someone got this on mac?
Please I need it

no, use windows or use the mono on mac-.-
dont annoy us with that crap 1000 times a day, ok?
NsmB_PrO
Member
Picture Resized!
Level: 43


Posts: 198/467
EXP: 527573
For next: 37473

Since: 04-29-10
From: Austria Vöcklabruck

Since last post: 6.0 years
Last activity: 4.0 years

Posted on 01-24-11 12:17:33 PM (last edited by NsmB_PrO at 01-24-11 12:50 PM) Link | Quote
bug report:

I have just used the new 3d texture editor in the revision 143 of the 5.2!
If I draw something in it and save, the last activitie I have done doesnt save-.-

I always have to edit twice to get what I want


Everytime I open the new revision, another screen (texture editor) opens! Could you do this away again?
dirbaio
For future reference, "Responsible disclosure" isn't "acting like a douche about an exploit and demanding compensation".
Level: NaN


Posts: 1112/-1288
EXP: NaN
For next: 0

Since: 07-28-09
From: Spain

Since last post: 6.0 years
Last activity: 5.0 years

Posted on 01-24-11 03:56:26 PM Link | Quote
Originally posted by NsmB_PrO
bug report:

I have just used the new 3d texture editor in the revision 143 of the 5.2!
If I draw something in it and save, the last activitie I have done doesnt save-.-

I always have to edit twice to get what I want


Everytime I open the new revision, another screen (texture editor) opens! Could you do this away again?


I removed the texture editor opening now.
I don't see what's your problem exactly. Explain it better / more detailed please
Pages: 1 2 3 4 5 6 7 8 9 10 ... 25 26 27 28 29 30 31 32 33 34Next newer thread | Next older thread
Jul - NSMB Hacking (Archive) - Editor Development thread New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 2f1bc75 [2017-08-27]
©2000-2017 Acmlm, Xkeeper, Inuyasha, et al.

30 database queries, 8 query cache hits.
Query execution time: 0.157359 seconds
Script execution time: 0.016428 seconds
Total render time: 0.173787 seconds