Register - Login
Views: 95492769
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - Stats - Latest Posts - Color Chart - Smilies
10-23-18 01:02:53 AM

Jul - SM64 Hacking (Archive) - Help/Questions about Toad's Tool 64 and SM64 hacking New poll - New thread - New reply
Pages: 1 2 3 4 5 6 7 8 9 10 ... 68 69 70 71 72 73 74 75 76 77Next older thread
Kaze
Member
Level: 17


Posts: 35/63
EXP: 23391
For next: 1352

Since: 10-25-12


Since last post: 2.0 years
Last activity: 2.0 years

Posted on 10-20-13 04:32:42 AM Link | Quote
Originally posted by skyluigi
If I enter a level that I've imported a model to, It black-screens. Am I doing something wrong?

yes
skyluigi

Level: 8


Posts: 2/11
EXP: 1560
For next: 627

Since: 10-19-13


Since last post: 3.0 years
Last activity: 3.0 years

Posted on 10-20-13 09:14:58 AM Link | Quote
Originally posted by Kaze
Originally posted by skyluigi
If I enter a level that I've imported a model to, It black-screens. Am I doing something wrong?

yes


Is there a way to fix it?
Kaze
Member
Level: 17


Posts: 36/63
EXP: 23391
For next: 1352

Since: 10-25-12


Since last post: 2.0 years
Last activity: 2.0 years

Posted on 10-21-13 07:43:40 AM Link | Quote
Originally posted by skyluigi
Originally posted by Kaze
Originally posted by skyluigi
If I enter a level that I've imported a model to, It black-screens. Am I doing something wrong?

yes


Is there a way to fix it?


sure, but you'll have to give some details like the importer version, emulator version, levelsize,... because there is a huge amount of mistakes, that you can make.
skyluigi

Level: 8


Posts: 3/11
EXP: 1560
For next: 627

Since: 10-19-13


Since last post: 3.0 years
Last activity: 3.0 years

Posted on 10-21-13 07:25:24 PM Link | Quote
Originally posted by Kaze

sure, but you'll have to give some details like the importer version, emulator version, levelsize,... because there is a huge amount of mistakes, that you can make.


Importer: Skelux's importer, 1.7S
Emulator: Project64 1.7
Levelsize: ????? Where do I find the levelsize?
Kaze
Member
Level: 17


Posts: 37/63
EXP: 23391
For next: 1352

Since: 10-25-12


Since last post: 2.0 years
Last activity: 2.0 years

Posted on 10-22-13 09:29:22 AM Link | Quote
Originally posted by skyluigi
Originally posted by Kaze

sure, but you'll have to give some details like the importer version, emulator version, levelsize,... because there is a huge amount of mistakes, that you can make.


Importer: Skelux's importer, 1.7S
Emulator: Project64 1.7
Levelsize: ????? Where do I find the levelsize?



the levelsize is the amount of faces (visible in the preview of the importer)
well, the problem can be, that it has too much faces. it can also be, that there's no correct match of warp IDs in your level. (look into the 0x26 warp destinations);
another reason can be some bad code, like putting objects with a wrong collision pointer, not working ASM,...
skyluigi

Level: 8


Posts: 4/11
EXP: 1560
For next: 627

Since: 10-19-13


Since last post: 3.0 years
Last activity: 3.0 years

Posted on 10-22-13 08:03:27 PM (last edited by skyluigi at 01-18-14 01:14:29 PM) Link | Quote
Originally posted by Kaze

the levelsize is the amount of faces (visible in the preview of the importer)
well, the problem can be, that it has too much faces. it can also be, that there's no correct match of warp IDs in your level. (look into the 0x26 warp destinations);
another reason can be some bad code, like putting objects with a wrong collision pointer, not working ASM,...


I finally got it working. The problem now is I get a blank blue screen in TT64.

Edit, 1 month and 13 days later: Is anyone ever going to answer this?
Celux

Red Cheep-cheep
Level: 31


Posts: 181/202
EXP: 174234
For next: 11129

Since: 09-21-08


Since last post: 3.0 years
Last activity: 71 days

Posted on 12-23-13 10:57:32 PM (last edited by Celux at 12-23-13 10:58:46 PM) Link | Quote
Originally posted by skyluigi
Originally posted by Kaze

the levelsize is the amount of faces (visible in the preview of the importer)
well, the problem can be, that it has too much faces. it can also be, that there's no correct match of warp IDs in your level. (look into the 0x26 warp destinations);
another reason can be some bad code, like putting objects with a wrong collision pointer, not working ASM,...


I finally got it working. The problem now is I get a blank blue screen in TT64.

Edit, 1 month and 13 days later: Is anyone ever going to answer this?


What operating system are you running?

You also might just be seeing the background because TT64 will not draw enough polygons to account for imported levels. Click the box which says something like "display collision map" near the bottom right corner of the application and the level should appear. Additionally, in the options screen of TT64 you must have "skip checksum" enabled.
FrittenFriseur
Random nobody
Level: 5


Posts: 2/5
EXP: 468
For next: 61

Since: 12-31-13


Since last post: 4.0 years
Last activity: 4.0 years

Posted on 01-01-14 04:57:19 PM Link | Quote
I have a big question!
Is someone here, who can make a complete Super Mario 64 Hacking Tutorial?

The Tutorial of Lugmillord is still nice, but I can't use newer things like custom objects...

It would be nice!
FrittenFriseur
Random nobody
Level: 5


Posts: 5/5
EXP: 468
For next: 61

Since: 12-31-13


Since last post: 4.0 years
Last activity: 4.0 years

Posted on 01-01-14 11:41:36 PM Link | Quote
Hey Guys.

I've extended a ROM-File to 64mb.
After that I patched the ROM with Skelux "SM64_Boundary_Patch_1.2.ppf" and with "obj_import18S.ppf" and of cause I've choosen an OBJ-File, replacing Bob-Omb-Battlefield.

After I had done this, I opened TT64 (Version 0.5994b), to insert some objects, but this error-message appears: "Not a valid ROM.

Please open a ROM that has been extended with the latest version of the Mario 64 ROM extender (currently 1.2b) But the strange thing: I had extended my ROM with the version 1.3. I don't understand, what I had done wrong.

Thanks for helping, guys!
Celux

Red Cheep-cheep
Level: 31


Posts: 186/202
EXP: 174234
For next: 11129

Since: 09-21-08


Since last post: 3.0 years
Last activity: 71 days

Posted on 01-02-14 10:15:57 AM (last edited by Celux at 01-02-14 10:17:31 AM) Link | Quote
Originally posted by FrittenFriseur
Hey Guys.

I've extended a ROM-File to 64mb.
After that I patched the ROM with Skelux "SM64_Boundary_Patch_1.2.ppf" and with "obj_import18S.ppf" and of cause I've choosen an OBJ-File, replacing Bob-Omb-Battlefield.

After I had done this, I opened TT64 (Version 0.5994b), to insert some objects, but this error-message appears: "Not a valid ROM.

Please open a ROM that has been extended with the latest version of the Mario 64 ROM extender (currently 1.2b) But the strange thing: I had extended my ROM with the version 1.3. I don't understand, what I had done wrong.

Thanks for helping, guys!


You don't need to do any of this manually, just open a regular 8MB SM64 ROM in importer 1.9 and the patching will be properly performed. After this, you'll need to enable skipping checksum in TT64.

Also, if metalman is still around, it's likely he'll beat you to death with a metal pipe for triple posting.
skyluigi

Level: 8


Posts: 5/11
EXP: 1560
For next: 627

Since: 10-19-13


Since last post: 3.0 years
Last activity: 3.0 years

Posted on 01-03-14 12:38:36 AM Link | Quote
Originally posted by Celux
Originally posted by skyluigi
Originally posted by Kaze

the levelsize is the amount of faces (visible in the preview of the importer)
well, the problem can be, that it has too much faces. it can also be, that there's no correct match of warp IDs in your level. (look into the 0x26 warp destinations);
another reason can be some bad code, like putting objects with a wrong collision pointer, not working ASM,...


I finally got it working. The problem now is I get a blank blue screen in TT64.

Edit, 1 month and 13 days later: Is anyone ever going to answer this?


What operating system are you running?

You also might just be seeing the background because TT64 will not draw enough polygons to account for imported levels. Click the box which says something like "display collision map" near the bottom right corner of the application and the level should appear. Additionally, in the options screen of TT64 you must have "skip checksum" enabled.


Sorry for taking so long to reply. I'm using Windows 7.
Lyskar
12210
-The Chaos within trumps the Chaos without-
Level: 185


Posts: 12093/12211
EXP: 86713976
For next: 1045759

Since: 07-03-07

From: 52-2-88-7

Since last post: 3.0 years
Last activity: 3.0 years

Posted on 01-03-14 03:07:38 AM Link | Quote
Originally posted by FrittenFriseur
I have a big question!
Is someone here, who can make a complete Super Mario 64 Hacking Tutorial?

The Tutorial of Lugmillord is still nice, but I can't use newer things like custom objects...

It would be nice!


Hey guys! Don't triple post!
skyluigi

Level: 8


Posts: 6/11
EXP: 1560
For next: 627

Since: 10-19-13


Since last post: 3.0 years
Last activity: 3.0 years

Posted on 01-18-14 11:20:47 PM (last edited by skyluigi at 01-18-14 11:23:12 PM) Link | Quote
Originally posted by Celux


What operating system are you running?

You also might just be seeing the background because TT64 will not draw enough polygons to account for imported levels. Click the box which says something like "display collision map" near the bottom right corner of the application and the level should appear. Additionally, in the options screen of TT64 you must have "skip checksum" enabled.


Sorry for taking so long to reply. I'm using Windows 7. (and version 1.8 of the importer).
Tdog61400
Random nobody
Level: 2


Posts: 1/1
EXP: 41
For next: 5

Since: 02-24-14


Since last post: 4.0 years
Last activity: 4.0 years

Posted on 02-24-14 09:51:15 PM Link | Quote
Hi
I have made a new hub world to replace the inside of the castle, but the objects that i place such as warp pipes dont appear unless I enable the level selector in toads tool, Is there any way to get the objects to appear without the level select or an act selector
Cackletta
Newcomer
;________;
Level: 6


Posts: 2/6
EXP: 607
For next: 300

Since: 02-19-14

From: los angeles, california

Since last post: 4.0 years
Last activity: 4.0 years

Posted on 03-16-14 05:57:03 AM Link | Quote
Originally posted by Tdog61400
Hi
I have made a new hub world to replace the inside of the castle, but the objects that i place such as warp pipes dont appear unless I enable the level selector in toads tool, Is there any way to get the objects to appear without the level select or an act selector

NO.
Lyskar
12210
-The Chaos within trumps the Chaos without-
Level: 185


Posts: 12117/12211
EXP: 86713976
For next: 1045759

Since: 07-03-07

From: 52-2-88-7

Since last post: 3.0 years
Last activity: 3.0 years

Posted on 03-16-14 07:07:48 PM Link | Quote
Screaming 'NO' at people in here, no matter how appropriate it may seem, is not permitted. A simple "No" or "Nope" or "Not to my knowledge" is good enough.
Cackletta
Newcomer
;________;
Level: 6


Posts: 3/6
EXP: 607
For next: 300

Since: 02-19-14

From: los angeles, california

Since last post: 4.0 years
Last activity: 4.0 years

Posted on 03-20-14 03:33:11 PM Link | Quote
Screaming? Nope, there wasn't an exclaimation mark, it was a simple no.
StapleButter
Member
Level: 42


Posts: 80/501
EXP: 509747
For next: 11615

Since: 02-24-13

From: your dreams

Since last post: 3 days
Last activity: 3 days

Posted on 03-20-14 03:34:45 PM Link | Quote
Typing in capital letters is often seen as the internet equivalent of shouting, fyi.
EthanGames
Newcomer
Level: 2


Posts: 1/1
EXP: 40
For next: 6

Since: 05-19-14

From: France

Since last post: 4.0 years
Last activity: 4.0 years

Posted on 05-19-14 05:07:31 AM Link | Quote
Hello! I have a problem with a level that I created.
I try to import the level with the importer levels Skelux but they say that the limit of the model size has been exceeded. My level looks like this:

Yet I put on my ROM Boundary Patch Skelux.
BMF54123

Rhea Snaketail
Slightly frazzled...
Level: 135


Posts: 5585/5866
EXP: 28872191
For next: 462814

Since: 07-03-07

From: Neither here nor there.

Since last post: 4 hours
Last activity: 3 hours

Posted on 05-20-14 12:30:42 AM Link | Quote
Yeesh...how many polygons do those stars have?
Pages: 1 2 3 4 5 6 7 8 9 10 ... 68 69 70 71 72 73 74 75 76 77Next older thread
Jul - SM64 Hacking (Archive) - Help/Questions about Toad's Tool 64 and SM64 hacking New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 5d36857 [2018-03-03]
©2000-2018 Acmlm, Xkeeper, Inuyasha, et al.

32 database queries, 5 query cache hits.
Query execution time: 0.320651 seconds
Script execution time: 0.030318 seconds
Total render time: 0.350969 seconds
Memory used: 786432