Register - Login
Views: 87369380
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - JCS - Stats - Latest Posts - Color Chart - Smilies
11-20-17 08:28:18 AM

Jul - SM64 Hacking - Help/Questions about Toad's Tool 64 and SM64 hacking New poll - New thread - New reply
Pages: 1 2 3 4 5 6 7 8 9 10 ... 69 70 71 72 73 74 75 76 77 78Next older thread
VL-Tone
Member
Super Mario 64 forum moderator
Level: 51


Posts: 1/621
EXP: 949999
For next: 63939

Since: 07-27-07
From: Montreal, Canada

Since last post: 83 days
Last activity: 52 days

Posted on 08-05-07 12:45:54 AM; last edit by VL-Tone on 08-05-07 04:17 AM Link | Quote
This thread is where you can ask questions about how to use TT64.

Please avoid asking questions that can be answered by reading the TT64 documentation.

I also recommend reading the newly updated TT64 FAQ if you haven't already.

The latest version of Toad's Tool 64 can be found on this page.

Edit: Added TT64's link and FAQ
Shadic
6820
Alakadoof?
Level: 142


Posts: 348/6829
EXP: 34666773
For next: 301656

Since: 07-22-07
From: Olympia, WA

Since last post: 1 day
Last activity: 1 day

Posted on 08-05-07 12:47:23 AM Link | Quote
Basic request... How about the link to the software?
OoBurns
?
Level: 57


Posts: 56/806
EXP: 1409145
For next: 76783

Since: 07-04-07
From: USA

Since last post: 5.0 years
Last activity: 5.0 years

Posted on 08-05-07 12:54:30 AM Link | Quote
Here is where you can download the latest version (currently 0.5b).
Big Cheese Make Me
User
She Eats Glue
Level: 9


Posts: 1/12
EXP: 2549
For next: 613

Since: 08-05-07
From: Mill Creek, West Virginia

Since last post: 7.0 years
Last activity: 7.0 years

Posted on 08-05-07 01:29:00 AM Link | Quote
How would I be able to move the trees with the shadows at the same time within the editor? I can't seem to find the object number for the tree shadow (s).
VL-Tone
Member
Super Mario 64 forum moderator
Level: 51


Posts: 3/621
EXP: 949999
For next: 63939

Since: 07-27-07
From: Montreal, Canada

Since last post: 83 days
Last activity: 52 days

Posted on 08-05-07 01:36:26 AM Link | Quote
Originally posted by Big Cheese Make Me
How would I be able to move the trees with the shadows at the same time within the editor? I can't seem to find the object number for the tree shadow (s).


Unfortunately, tree shadows are part of the level geometry, so you can't move them with the trees. Some other objects have their own shadows that will move with the object, but trees are not part of these.
Big Cheese Make Me
User
She Eats Glue
Level: 9


Posts: 2/12
EXP: 2549
For next: 613

Since: 08-05-07
From: Mill Creek, West Virginia

Since last post: 7.0 years
Last activity: 7.0 years

Posted on 08-05-07 02:10:51 AM Link | Quote
I am just curious, where is the water in the editor?
was it not implemented due to it's animation,
or perhaps as it was too big to import into the editor,
and more curious, is it perhaps at all editable, or is it possible,
even for thought in a future release?
VL-Tone
Member
Super Mario 64 forum moderator
Level: 51


Posts: 4/621
EXP: 949999
For next: 63939

Since: 07-27-07
From: Montreal, Canada

Since last post: 83 days
Last activity: 52 days

Posted on 08-05-07 02:20:13 AM Link | Quote
Water editing is not implemented in TT64. I don't know how it's stored, and I'm not sure where the water commands are, but I know they're not part of the commands that TT64 currently edits.

I suspect they're found just after the 0x43 command data, and this is an area I have to know better.
Deleted User
Original user deleted
Level: NaN


Posts: 1/-8234
EXP: NaN
For next: 0

Since: 07-26-07


Since last post: 10.0 years
Last activity: 7.0 years

Posted on 08-05-07 08:44:26 AM Link | Quote
Wow, this is a nice forum! I'm still having problems with the black screen... still don't know why or how it happened, but it really needs to be fixed before I release my mod.
Xtreme Starfox
180
Level: 30


Posts: 1/180
EXP: 148081
For next: 17788

Since: 08-05-07
From: I don't know, Seriously.

Since last post: 8.0 years
Last activity: 7.0 years

Posted on 08-05-07 10:35:51 AM Link | Quote
You Can Level Up In This Forum........?


CrashDunce22 What Graphics Plugin Are You Using On Your Emulator?

Because That Might Be The Problem Some Of My Plugins I Have In the Emulator Makes It Black.
John2k4
490
Bubble Bobble
Level: 46


Posts: 1/499
EXP: 683501
For next: 28273

Since: 08-05-07
From: Arizona

Since last post: 4.0 years
Last activity: 3.0 years

Posted on 08-05-07 11:50:35 AM Link | Quote
Maybe change the Add PNG button in the texture editor to import picture, because my .GIF's, and .JPEG's work fine.
Deleted User
Original user deleted
Level: NaN


Posts: 2/-8234
EXP: NaN
For next: 0

Since: 07-26-07


Since last post: 10.0 years
Last activity: 7.0 years

Posted on 08-05-07 12:58:39 PM Link | Quote
Holy... you're right Xtreme Starfox! It's fixed, yay!!!
But still, I've had that problem before... I guess it's just a plugin bug. I was using Jabo's Direct3D8 1.6 when it happened, then I switched to 1.5.2 then back to 1.6, and it worked again! It still worked when I switched back to 1.5.2.
Rena

Star Mario
Fennel
Level: 127


Posts: 504/5239
EXP: 23295371
For next: 431195

Since: 07-22-07
From: RSP Segment 6

Since last post: 93 days
Last activity: 51 days

Posted on 08-05-07 02:16:30 PM; last edit by HyperHacker on 08-05-07 05:17 PM Link | Quote
Originally posted by VL-Tone
Water editing is not implemented in TT64. I don't know how it's stored, and I'm not sure where the water commands are, but I know they're not part of the commands that TT64 currently edits.

I suspect they're found just after the 0x43 command data, and this is an area I have to know better.
There are Gameshark codes that change the "water height" to make swim-in-air (height=32767) or walk-underwater (height=-32768) effects. The water polygons themselves don't move, but water interaction seems to be a simple Y position check.

Given the variable water level outside the castle and in Wet-Dry World, I'd guess the height is set by the script.
Deleted User
Original user deleted
Level: NaN


Posts: 1/-8234
EXP: NaN
For next: 0

Since: 07-26-07


Since last post: 10.0 years
Last activity: 7.0 years

Posted on 08-05-07 02:48:11 PM Link | Quote
I need help, will someone please help me? when I replace the double-doors outside the castle with metal doors something happens. I enter the left metal door and I get stuck in that legendary test room. It also happens when I enter the right door inside the castle. How do I fix this? I already tried flip-flopping the doors in all possible combos, is there another way to fix it?
Xtreme Starfox
180
Level: 30


Posts: 4/180
EXP: 148081
For next: 17788

Since: 08-05-07
From: I don't know, Seriously.

Since last post: 8.0 years
Last activity: 7.0 years

Posted on 08-05-07 05:09:10 PM Link | Quote
Dudaw Did I not all ready say this? One of your Doors are backwards.....
Deleted User
Original user deleted
Level: NaN


Posts: 9/-8234
EXP: NaN
For next: 0

Since: 07-26-07


Since last post: 10.0 years
Last activity: 7.0 years

Posted on 08-05-07 05:18:41 PM Link | Quote
Xtreme Starfox: I said, I already tried all possible combos on flip-flopping the doors!
Any way I flip-flop the doors, it still happens.
Deleted User
Original user deleted
Level: NaN


Posts: 1004/-8234
EXP: NaN
For next: 0

Since: 07-26-07


Since last post: 10.0 years
Last activity: 7.0 years

Posted on 08-05-07 05:20:09 PM Link | Quote
Originally posted by Dudaw
Xtreme Starfox: I said, I already tried all possible combos on flip-flopping the doors!
Any way I flip-flop the doors, it still happens.

Wait, did you say test room?

There is no test room AFAIK.

Provide a screenshot of your error.
Xtreme Starfox
180
Level: 30


Posts: 7/180
EXP: 148081
For next: 17788

Since: 08-05-07
From: I don't know, Seriously.

Since last post: 8.0 years
Last activity: 7.0 years

Posted on 08-05-07 05:24:59 PM Link | Quote
He Means Behind The Doors In The Castle....
John2k4
490
Bubble Bobble
Level: 46


Posts: 11/499
EXP: 683501
For next: 28273

Since: 08-05-07
From: Arizona

Since last post: 4.0 years
Last activity: 3.0 years

Posted on 08-05-07 05:28:40 PM Link | Quote
Oh, the black room?
Thats easy to get out of (if u can get behind doors inside)
Deleted User
Original user deleted
Level: NaN


Posts: 10/-8234
EXP: NaN
For next: 0

Since: 07-26-07


Since last post: 10.0 years
Last activity: 7.0 years

Posted on 08-05-07 05:30:10 PM Link | Quote
Of course Xtreme Starfox. Take a look at the picture below Grey Mario.
http://web.mac.com/qubedstudios/iWeb/Site/Blog/981736A6-78B4-4483-A8FE-5158280C4F05.html/wsc/44D750B6-0113-1000-83FC-F174D604263F/12.JPG?wsc=download
Deleted User
Original user deleted
Level: NaN


Posts: 1006/-8234
EXP: NaN
For next: 0

Since: 07-26-07


Since last post: 10.0 years
Last activity: 7.0 years

Posted on 08-05-07 05:33:03 PM; last edit by Grey Mario on 08-05-07 08:33 PM Link | Quote
Originally posted by Dudaw
Of course Xtreme Starfox. Take a look at the picture below Grey Mario.
long URL

Yes, one of the doors is backwards.

I haven't used TT64 so I have no idea what you might have screwed up. Maybe VL-Tone can tell you when he gets back into this thread.
Pages: 1 2 3 4 5 6 7 8 9 10 ... 69 70 71 72 73 74 75 76 77 78Next older thread
Jul - SM64 Hacking - Help/Questions about Toad's Tool 64 and SM64 hacking New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 2f1bc75 [2017-08-27]
©2000-2017 Acmlm, Xkeeper, Inuyasha, et al.

28 database queries, 3 query cache hits.
Query execution time: 0.192461 seconds
Script execution time: 0.016808 seconds
Total render time: 0.209269 seconds