Register - Login
Views: 86580326
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - JCS - Stats - Latest Posts - Color Chart - Smilies
10-22-17 01:35:01 AM

Jul - SM64 Hacking - Super Mario 64: The Missing Stars RELEASED! (Download link on first post) New poll - New thread - New reply
Pages: 1 2 3 4 5 6 7 8 9 10 ... 16 17 18 19 20 21 22 23 24 25 26 27Next newer thread | Next older thread
RDX

Level: 30


Posts: 67/198
EXP: 156909
For next: 8960

Since: 02-14-09


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 05-02-09 06:28:48 PM (last edited by RDX at 05-02-09 06:36 PM) Link | Quote
Yeah, Messiaen, that's why we couldn't finish that course back when we were beta testing. It's because the iron crates aren't pushable.

Anyways I haven't seen any errors. The SMB3 song in Koopa's area still doesn't loop, and the Star Select screen for the Secret Woods at night is navy blue and it's difficult to read the objective names. But I haven't seen any new errors. There's a little more slow down, but it's not game breaking.

Also, are you sure there are 3 stars in the underground?

[nvm that was a stupid question]

(also also whats the name of the song that plays during the day in the secret woods? it sounds like smb2 but i couldnt quite figure what it was. it works really well with the level though)
wwwarea
Member
Level: 20


Posts: 42/74
EXP: 36900
For next: 5539

Since: 08-09-08


Since last post: 5.0 years
Last activity: 4.0 years

Posted on 05-02-09 06:31:41 PM (last edited by wwwarea at 05-02-09 06:32 PM) Link | Quote
I also found another glitch. When im in the place with the volcano, then ride the lift and after I pass the chain chomp, then go higher with another lift then the part when it goes high, the lift goes of the screen map and then I fall. Is that fixed?
messiaen
Catgirl
Level: 64


Posts: 569/1085
EXP: 2151323
For next: 62774

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 06:33:04 PM (last edited by messiaen at 05-02-09 06:39 PM) Link | Quote
Originally posted by RDX
Yeah, Messiaen, that's why we couldn't finish that course back when we were beta testing. It's because the iron crates aren't pushable.

Anyways I haven't seen any errors. The SMB3 song in Koopa's area still doesn't loop, and the Star Select screen for the Secret Woods at night is navy blue and it's difficult to read the objective names. But I haven't seen any new errors. There's a little more slow down, but it's not game breaking.

Also, are you sure there are 3 stars in the underground?

(also i noticed you didnt change the boss theme. did you forget or did you decide that the original worked well enough?)

(also also whats the name of the song that plays during the day in the secret woods? it sounds like smb2 but i couldnt quite figure what it was. it works really well with the level though)


The iron crates aren't pushable, but there is a way to get the red coin under them .

Ops, I forgot to correct the loop in SMB3, that should make in a future v1.1 release with more bugfixes. I noticed that the first area is a bit more slow, and its mostly due to NPCs. For the v1.1 release I'll use them more sparingly (some of them aren't really needed) to avoid slowdowns (did you notice how the night is much smoother?)

There are 3 stars in the underground, the fly guy gives you a hint about it.

The song in The Secret Woods is from Yoshi Island 2 (DS version).

wwwarea: can you post a screenshot of it so I can know exactly what is the troublesome spot?
RDX

Level: 30


Posts: 68/198
EXP: 156909
For next: 8960

Since: 02-14-09


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 05-02-09 06:47:45 PM (last edited by RDX at 05-02-09 07:00 PM) Link | Quote
oh, haha, im an idiot for not trying that

though when it's over it doesnt disappear like its supposed to

The Final Battle is kickass. Seriously, it's awesome
Peach still kisses the air. But I guess that can't be helped. And it doesn't look all that awkward

And...I'm done. I didn't see any errors, but apparently others did. Great job, man.
wwwarea
Member
Level: 20


Posts: 43/74
EXP: 36900
For next: 5539

Since: 08-09-08


Since last post: 5.0 years
Last activity: 4.0 years

Posted on 05-02-09 06:54:26 PM Link | Quote
images/photobucket.png#http://i250.photobucket.com/albums/gg244/wwwarea/snap0035.jpg

This is what I mean. The lift goes off and I cant go further. It goes past the invisible wall and pushing Mario off the lift.

But for some reason now. Theres no music when I went in that map again.
messiaen
Catgirl
Level: 64


Posts: 570/1085
EXP: 2151323
For next: 62774

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 07:01:08 PM Link | Quote
Originally posted by wwwarea
images/photobucket.png#http://i250.photobucket.com/albums/gg244/wwwarea/snap0035.jpg

This is what I mean. The lift goes off and I cant go further. It goes past the invisible wall and pushing Mario off the lift.

But for some reason now. Theres no music when I went in that map again.


Nice find, the lift wasn't supposed to go there, there's probably an error in the last coordinate. Already included in my To Do list for v1.1 . With so much stuff in the hack, it's easy to overlook these small things.
RDX

Level: 30


Posts: 69/198
EXP: 156909
For next: 8960

Since: 02-14-09


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 05-02-09 07:02:30 PM (last edited by RDX at 05-02-09 07:02 PM) Link | Quote
For the record, my lift went along fine. So it's probably not a universal issue.

Same with that major bug you found. So I imagine that others who play the hack probably won't come across it.
wwwarea
Member
Level: 20


Posts: 44/74
EXP: 36900
For next: 5539

Since: 08-09-08


Since last post: 5.0 years
Last activity: 4.0 years

Posted on 05-02-09 07:14:29 PM Link | Quote
Oh, it works for you fine? I wonder how do I fix it for me? I did patch it with the correct rom. The bug happens on both versions too.
Bob-omb8194
Still Explodin'
Level: 75


Posts: 261/1654
EXP: 3785119
For next: 41785

Since: 02-19-09
From: NC, US

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 05-02-09 07:18:09 PM Link | Quote
The Major bug thing I found works better now. I'm up to 8 stars, and I'm still finding more.
messiaen
Catgirl
Level: 64


Posts: 571/1085
EXP: 2151323
For next: 62774

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 07:18:34 PM Link | Quote
Maybe RDX tried the wrong lift, its the lift after Chain-Chomp we're talking about.

Anyway, keep coming with things to be corrected, hopefully v1.1 will be the 'final' release .
wwwarea
Member
Level: 20


Posts: 45/74
EXP: 36900
For next: 5539

Since: 08-09-08


Since last post: 5.0 years
Last activity: 4.0 years

Posted on 05-02-09 07:23:17 PM (last edited by wwwarea at 05-02-09 07:25 PM) Link | Quote
OK, but I was thinking that you locked moon jump but it was still working, and when I read the sign to the woods. It saids Hi there. I think that was ment to go to the red/pink bomb.

EDIT: When I go to the woods I get the star screen but it looks weird, like its black or something and a little white around the corse thing.
RDX

Level: 30


Posts: 70/198
EXP: 156909
For next: 8960

Since: 02-14-09


Since last post: 6.0 years
Last activity: 5.0 years

Posted on 05-02-09 07:23:55 PM Link | Quote
Oh, I didn't even bother to use that lift. My bad. I always forget that it's there.
messiaen
Catgirl
Level: 64


Posts: 572/1085
EXP: 2151323
For next: 62774

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 07:25:37 PM Link | Quote
Originally posted by wwwarea
OK, but I was thinking that you locked moon jump but it was still working, and when I read the sign to the woods. It saids Hi there. I think that was ment to go to the red/pink bomb.


The Moon Jump code was a bit different than what I thought, so it would be too hard to disable it. I'll check about that sign.
wwwarea
Member
Level: 20


Posts: 46/74
EXP: 36900
For next: 5539

Since: 08-09-08


Since last post: 5.0 years
Last activity: 4.0 years

Posted on 05-02-09 07:30:33 PM (last edited by wwwarea at 05-02-09 07:31 PM) Link | Quote
OK. =) I did also edit that thing. It also had another bug about the star select screen. The white turned into black and only a little white shows in the middle. Only happens when I go to the woods.
messiaen
Catgirl
Level: 64


Posts: 573/1085
EXP: 2151323
For next: 62774

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 07:41:55 PM Link | Quote
Originally posted by wwwarea
OK. =) I did also edit that thing. It also had another bug about the star select screen. The white turned into black and only a little white shows in the middle. Only happens when I go to the woods.


I know this one for ages, but I'm not sure what is causing it .
Grawly
User
Level: 8


Posts: 4/10
EXP: 1781
For next: 406

Since: 02-12-09


Since last post: 6.0 years
Last activity: 6.0 years

Posted on 05-02-09 07:56:07 PM Link | Quote
Litteraly just noticed you said not to play. Didn't read the thread till now.
Yeah, upgraded, anyway...

...not sure if you did it on purpose, but in the Main City Area, if you shimmy around the pipe with the cannon, Mario will go inside it if the camera hides him behind the pipe. Kinda hard to explain, sorry.
Stevoisiak
Member
Level: 36


Posts: 256/283
EXP: 286487
For next: 21623

Since: 11-22-07
From: New York, Long Island

Since last post: 7.0 years
Last activity: 1.0 years

Posted on 05-02-09 08:07:07 PM (last edited by Stevoisiak at 05-02-09 08:07 PM) Link | Quote
Originally posted by messiaen
Originally posted by wwwarea
OK. =) I did also edit that thing. It also had another bug about the star select screen. The white turned into black and only a little white shows in the middle. Only happens when I go to the woods.


I know this one for ages, but I'm not sure what is causing it .

It has to do with night-time mode. When its night in the hack, the level select turns dark too! I told you that during beta testing, remeber? And I really don't see why Secret Woods needs a star select. The lava level, maybe, but Secret woods, no. Especially since I often climb up a hill or go to an area then figure out I was chasing the wrong star. Also, I see the cannon bug is still there. Oh well. A first release is nice. Cant wait to see the new boss fight!
messiaen
Catgirl
Level: 64


Posts: 574/1085
EXP: 2151323
For next: 62774

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 08:24:58 PM (last edited by messiaen at 05-02-09 08:25 PM) Link | Quote
Originally posted by Stevoisiak
It has to do with night-time mode. When its night in the hack, the level select turns dark too! I told you that during beta testing, remeber? And I really don't see why Secret Woods needs a star select. The lava level, maybe, but Secret woods, no. Especially since I often climb up a hill or go to an area then figure out I was chasing the wrong star. Also, I see the cannon bug is still there. Oh well. A first release is nice. Cant wait to see the new boss fight!


I know it's related to the night stuff, but I still don't have a clue why it happens so I don't know how to fix it.
The cannon bug is another hard to fix bug, I tried increasing the pipe size but it didn't make a difference. Overall, the collision bugs are the worst, for instance, I had to change the way to get to Secret Woods because I couldn't solve the bug between Metal Mario and the underwater breakable boxes.

The problem about removing the act selectors in Secret Woods is the cannon in the middle. The first three stars would be much easier if the cannon was acessible, and if I remove it, the "Tree Tops" act would have to be changed. There's also the problem of possible slowdowns with all objects being showed at once.

I guess I'll try again and see if I can finally solve the problem with the act selector during nighttime. Strangely it doesn't happen in the Volcano level.
Stevoisiak
Member
Level: 36


Posts: 257/283
EXP: 286487
For next: 21623

Since: 11-22-07
From: New York, Long Island

Since last post: 7.0 years
Last activity: 1.0 years

Posted on 05-02-09 08:29:15 PM Link | Quote
Originally posted by messiaen
I know it's related to the night stuff, but I still don't have a clue why it happens so I don't know how to fix it.
The cannon bug is another hard to fix bug, I tried increasing the pipe size but it didn't make a difference. Overall, the collision bugs are the worst, for instance, I had to change the way to get to Secret Woods because I couldn't solve the bug between Metal Mario and the underwater breakable boxes.

The problem about removing the act selectors in Secret Woods is the cannon in the middle. The first three stars would be much easier if the cannon was acessible, and if I remove it, the "Tree Tops" act would have to be changed. There's also the problem of possible slowdowns with all objects being showed at once.

I guess I'll try again and see if I can finally solve the problem with the act selector during nighttime. Strangely it doesn't happen in the Volcano level.

Well, for the cannon, just limit it's rotation like they did in the origional!
VL-Tone
Member
Super Mario 64 forum moderator
Level: 50


Posts: 470/621
EXP: 946295
For next: 1022

Since: 07-27-07
From: Montreal, Canada

Since last post: 54 days
Last activity: 23 days

Posted on 05-02-09 10:26:13 PM (last edited by VL-Tone at 05-02-09 10:26 PM) Link | Quote
messiaen:

I didn't have time to check the mod yet, but I just uploaded a new version of the ROM extender: 1.3b, which mainly addresses the problem with the different padding bytes between platforms.

The only important difference in 1.3b is in the Mac version, the padding is now done using 0x01 instead of 0xFF, to match the Windows version. Mod patches for Windows ROMs should now work on Mac ROM extended using 1.3b

In the Windows version, I added a dummy text file to the MIO0files folder to make sure that it gets unzipped (for some reason, some unzipping utilities on Windows don't extract empty folders)

If you are on Windows and your ROM extender already works, you don't need version 1.3b.

The M64 ROM Extender v1.3b can be downloaded on this page:

http://homepage.mac.com/qubedstudios/Mario64Tools.htm

Here's a direct link to the Mac version: http://homepage.mac.com/qubedstudios/M64ROMExtender1.3bMac.zip
Pages: 1 2 3 4 5 6 7 8 9 10 ... 16 17 18 19 20 21 22 23 24 25 26 27Next newer thread | Next older thread
Jul - SM64 Hacking - Super Mario 64: The Missing Stars RELEASED! (Download link on first post) New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 2f1bc75 [2017-08-27]
©2000-2017 Acmlm, Xkeeper, Inuyasha, et al.

30 database queries, 10 query cache hits.
Query execution time: 0.166038 seconds
Script execution time: 0.016195 seconds
Total render time: 0.182233 seconds