Register - Login
Views: 87822112
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - JCS - Stats - Latest Posts - Color Chart - Smilies
12-14-17 08:26:33 AM

Jul - SM64 Hacking - Super Mario 64: The Missing Stars RELEASED! (Download link on first post) New poll - New thread - New reply
Pages: 1 2 3 4 5 6 7 8 9 10 ... 15 16 17 18 19 20 21 22 23 24 25 26 27Next newer thread | Next older thread
m4ck
Member
Level: 12


Posts: 18/27
EXP: 7900
For next: 21

Since: 04-09-09


Since last post: 8.0 years
Last activity: 6.0 years

Posted on 05-02-09 04:46:16 PM (last edited by m4ck at 05-02-09 04:48 PM) Link | Quote
Well, seems great ^^ Unfortunately I cannot enjoy it right now(11 p.m. here), but I'll spend most of sunday playing it :]
To wwwarea - what emulator are you using? it works fine for me on Project64, version 1.6 or something about that.
Bob-omb8194
Still Explodin'
Level: 75


Posts: 255/1654
EXP: 3816861
For next: 10043

Since: 02-19-09
From: NC, US

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 05-02-09 04:53:46 PM Link | Quote
The error was for PJ 1.7. I got it to work for PJ 1.6.

EXCELLENT WORK!!!!!

The ASM hacking is incredible! I'm not sure were to start, but you did a great job!!!


It will take some time to get even 10 stars, but it's worth it!
wwwarea
Member
Level: 20


Posts: 38/74
EXP: 37191
For next: 5248

Since: 08-09-08


Since last post: 5.0 years
Last activity: 5.0 years

Posted on 05-02-09 04:53:50 PM Link | Quote
Well, I tried both 1.7 and 1.6 and it sort of does the same thing.
messiaen
Catgirl
Level: 64


Posts: 562/1085
EXP: 2167096
For next: 47001

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 04:56:09 PM Link | Quote
Originally posted by Bob-omb8194
It hates me.

I give PJ64 More memory and everytime I try to play I get Inflinate memory error codes. Also, 1964 Kicks me off at the title screen.

It looks like this:



What did I do wrong?


Not sure, what version of PJ64 are you using? I've tested both in PJ 1.4 (Build 52) and 1.6. Do you get these during gameplay or before the title screen? Have you turned Extended Memory both in ROM settings and General settings? Also, are you sure you patched to a clear extended ROM (and the right version of the patch, not the mac one) ?
m4ck
Member
Level: 12


Posts: 19/27
EXP: 7900
For next: 21

Since: 04-09-09


Since last post: 8.0 years
Last activity: 6.0 years

Posted on 05-02-09 04:58:00 PM Link | Quote
Strange. All I did was picking the normal file I used to play, extending it, applying the patch using tools given on messiaen site and after changing the memory size launching rom. Worked like it should - after tiny problem with controller, but it was only my fault.
messiaen
Catgirl
Level: 64


Posts: 563/1085
EXP: 2167096
For next: 47001

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 05:02:58 PM Link | Quote
The only thing that can wrong after the patch is applied is the extended memory setting on PJ64. The thing to remember is that even after the "Default Memory Size" is set to 8MB, you will still have to load the rom and go to "ROM settings" and change the Memory Size there to 8MB as well.
wwwarea
Member
Level: 20


Posts: 39/74
EXP: 37191
For next: 5248

Since: 08-09-08


Since last post: 5.0 years
Last activity: 5.0 years

Posted on 05-02-09 05:07:52 PM (last edited by wwwarea at 05-02-09 05:09 PM) Link | Quote
Didn't work. I cant even open it in toads tool.

EDIT: Yeah it works but only in 1.6 but I wonder why I cant open it in toads tool. Yeah, if I edit a level I promise I will give credit.
mario 64 fan
Random nobody
Level: 5


Posts: 3/3
EXP: 295
For next: 234

Since: 02-08-09


Since last post: 8.0 years
Last activity: 8.0 years

Posted on 05-02-09 05:08:11 PM Link | Quote
Originally posted by Bob-omb8194
It hates me.

I give PJ64 More memory and everytime I try to play I get Inflinate memory error codes. Also, 1964 Kicks me off at the title screen.

It looks like this:



What did I do wrong?


go to Projekt 64 1.6
then click on options
>settings>RomSettings>Memory Size>8MB
Bob-omb8194
Still Explodin'
Level: 75


Posts: 256/1654
EXP: 3816861
For next: 10043

Since: 02-19-09
From: NC, US

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 05-02-09 05:09:28 PM Link | Quote
Massive glitch (or either E. Egg) found. Sent to Messiaen via PM. TOP SECRET.
messiaen
Catgirl
Level: 64


Posts: 564/1085
EXP: 2167096
For next: 47001

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 05:23:39 PM (last edited by messiaen at 05-02-09 05:24 PM) Link | Quote
Originally posted by Bob-omb8194
Massive glitch (or either E. Egg) found. Sent to Messiaen via PM. TOP SECRET.


I couldn't reproduce your bug, but then this is something I have hardly tested. Please send me a very detailed report (number of stars, emulator you were using), if it happens on a specific ocassion I have anidea for a fix.
m4ck
Member
Level: 12


Posts: 20/27
EXP: 7900
For next: 21

Since: 04-09-09


Since last post: 8.0 years
Last activity: 6.0 years

Posted on 05-02-09 05:25:46 PM Link | Quote
TOP SECRET... I guess it must be something really inteesting. Would you mind explaining this to us one day?
messiaen
Catgirl
Level: 64


Posts: 565/1085
EXP: 2167096
For next: 47001

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 05:29:16 PM (last edited by messiaen at 05-02-09 05:32 PM) Link | Quote
Originally posted by m4ck
TOP SECRET... I guess it must be something really inteesting. Would you mind explaining this to us one day?


I am waiting for more info, but meanwhile I took the hack out of the site because it (might be) a very serious bug. I took the hack down until I investigate more.
wwwarea
Member
Level: 20


Posts: 40/74
EXP: 37191
For next: 5248

Since: 08-09-08


Since last post: 5.0 years
Last activity: 5.0 years

Posted on 05-02-09 05:35:57 PM Link | Quote
Hey, messiaen? I can play the hack now on P 1.6 but I dont think I can use it for toads tool. I was wondering if you some how locked the hack or something for toads tool.
M. Bison

Level: 8


Posts: 6/11
EXP: 2074
For next: 113

Since: 02-07-09


Since last post: 4.0 years
Last activity: 2.0 years

Posted on 05-02-09 05:37:32 PM Link | Quote
I can't play it on ANY emulator; the furthest I can get in Mupen and Project 64 1.6 is the select screen; if I select a file, the game just stays on the white fade-out.
Bob-omb8194
Still Explodin'
Level: 75


Posts: 257/1654
EXP: 3816861
For next: 10043

Since: 02-19-09
From: NC, US

Since last post: 6.0 years
Last activity: 6.0 years

Posted on 05-02-09 05:41:36 PM (last edited by Bob-omb8194 at 05-02-09 06:10 PM) Link | Quote
Announcment: The download is down, so Messiaen can fix a MAJOR Bug. In the mean time, People with the hack can look for more bugs.


Please report Major bugs directly to Messiaen (PM), because the one I found was important.
messiaen
Catgirl
Level: 64


Posts: 566/1085
EXP: 2167096
For next: 47001

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 05:52:14 PM (last edited by messiaen at 05-02-09 05:52 PM) Link | Quote
Here's the deal. There was a VERY serious bug related to one last minute modification I did on the ROM.
I have fixed it but I"m testing it a bit more. In about 1 hour I'll upload a new corrected version of the hack. There are some other minor problems I spotted, but I won't be touching these right now.

I seriously recommend that people give a break playing the hack and wait for the fix, because it's a really major issue. I will upload it very soon.

If anyone find other (hopefully minor) bugs, just send me a PM.
Grawly
User
Level: 8


Posts: 3/10
EXP: 1796
For next: 391

Since: 02-12-09


Since last post: 6.0 years
Last activity: 6.0 years

Posted on 05-02-09 05:53:48 PM Link | Quote
Well, the hack it working A.OK on my Mac with Sixtyforce.
Also, I used PPFMaster.

Loving it so far, but my only complaint is the camera can be a bit stubborn sometimes. :3
messiaen
Catgirl
Level: 64


Posts: 567/1085
EXP: 2167096
For next: 47001

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 05:58:20 PM Link | Quote
Originally posted by wwwarea
Hey, messiaen? I can play the hack now on P 1.6 but I dont think I can use it for toads tool. I was wondering if you some how locked the hack or something for toads tool.



There are many modifications on the ROM that make it incompatible with TT64. The levels were actually worked in a few different files, then put together (manually) on a "Master ROM".
wwwarea
Member
Level: 20


Posts: 41/74
EXP: 37191
For next: 5248

Since: 08-09-08


Since last post: 5.0 years
Last activity: 5.0 years

Posted on 05-02-09 06:01:02 PM (last edited by wwwarea at 05-02-09 06:02 PM) Link | Quote
I don't know if this is a bug but I cant seem to move the crates and someone in the hack saids that theres something under the crates. The crates at the map with the forest song and theres this crate area formed into a plus but cant move any of them.

EDIT: Oh, I see. But it would be cool if we could make are own levels out of the hack.
messiaen
Catgirl
Level: 64


Posts: 568/1085
EXP: 2167096
For next: 47001

Since: 11-20-07


Since last post: 3.0 years
Last activity: 2.0 years

Posted on 05-02-09 06:27:37 PM (last edited by messiaen at 05-02-09 06:33 PM) Link | Quote
Major bug fixed! Thanks a lot to Bob-omb8194 for reporting it.

Download The Missing Stars v1.0b.

Your save data won't be lost once you load the new ROM. Please upgrade it to avoid a very serious bug.
Pages: 1 2 3 4 5 6 7 8 9 10 ... 15 16 17 18 19 20 21 22 23 24 25 26 27Next newer thread | Next older thread
Jul - SM64 Hacking - Super Mario 64: The Missing Stars RELEASED! (Download link on first post) New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 2f1bc75 [2017-08-27]
©2000-2017 Acmlm, Xkeeper, Inuyasha, et al.

30 database queries, 11 query cache hits.
Query execution time: 0.219546 seconds
Script execution time: 0.014711 seconds
Total render time: 0.234257 seconds