Register - Login
Views: 91905226
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - Stats - Latest Posts - Color Chart - Smilies
06-19-18 06:36:25 PM

Jul - Craziness Domain - The OS of the future: AcmlmOS New poll - New thread - New reply
Pages: 1 2Next newer thread | Next older thread
StapleButter
Member
Level: 41


Posts: 162/486
EXP: 472033
For next: 8112

Since: 02-24-13

From: your dreams

Since last post: 26 days
Last activity: 4 days

Posted on 01-14-16 06:59:13 PM Link | Quote
You are stuck into an alternate timeline where Acmlm coded an OS instead of a messageboard software.


You turn your computer on. You are greeted by the BIOS splashscreen, promptly followed by that familiar banner... AcmlmOS.

The OS is themed exactly the way you want, but that took quite some time. The AcmlmOS graphics layer can be customized by inserting your own code into it.

The design is simple and straightforward. You instantly find the web browser, and browse Jul. Well, it runs off IPB.

You enter this thread and post from your AcmlmOS-powered PC.


Your turn.
Zeether

Level: 29


Posts: 39/213
EXP: 142280
For next: 5605

Since: 09-23-12


Since last post: 75 days
Last activity: 29 days

Posted on 01-14-16 11:32:33 PM Link | Quote
I'm recording a TAS using this OS.
devin

King Bowser Koopa
i'm mima irl
Level: 106


Posts: 3185/3447
EXP: 12315347
For next: 356596

Since: 04-29-08

Pronouns: any
From: FL

Since last post: 17 days
Last activity: 5 days

Posted on 01-14-16 11:36:46 PM (last edited by devin at 01-14-16 11:36:59 PM) Link | Quote
Originally posted by StapleButter
You turn your computer on. You are greeted by the BIOS splashscreen

ah... the Fun POSTing Experience
Zeether

Level: 29


Posts: 42/213
EXP: 142280
For next: 5605

Since: 09-23-12


Since last post: 75 days
Last activity: 29 days

Posted on 01-16-16 04:23:42 PM Link | Quote
Will this OS run Crysis at maximum settings
Kak
heh
Level: 71


Posts: 1499/1780
EXP: 3141998
For next: 25116

Since: 09-03-13

From: ???

Since last post: 6 days
Last activity: 1 day

Posted on 01-16-16 04:51:49 PM (last edited by Schezo at 01-16-16 05:04:06 PM) Link | Quote
Why are there people still using AcmlmOS 1.A3 with Acmlm Explorer 6 to this day. It's sad.
Zeether

Level: 29


Posts: 43/213
EXP: 142280
For next: 5605

Since: 09-23-12


Since last post: 75 days
Last activity: 29 days

Posted on 01-16-16 09:00:33 PM Link | Quote
Only Acmlm makes it possible.
RanAS
Member
Level: 38


Posts: 136/441
EXP: 340051
For next: 30396

Since: 10-10-14

From: Brazil

Since last post: 2 days
Last activity: 1 min.

Posted on 01-17-16 04:41:07 AM (last edited by RanAS at 01-17-16 04:41:55 AM) Link | Quote
Originally posted by Schezo
Why are there people still using AcmlmOS 1.A3 with Acmlm Explorer 6 to this day. It's sad.

AcmlmOS 1.A3? There's the issue. You need to revert back to 1.92! At once!
xdaniel
740
Level: 54


Posts: 615/743
EXP: 1195483
For next: 38387

Since: 12-04-08

Pronouns: he/him
From: Germany

Since last post: 5 days
Last activity: 35 min.

Posted on 01-17-16 08:18:54 AM Link | Quote
AcmlmOS is fine, it runs well on almost all of my systems - the old 1.5x PowerPC builds run nicely on my PowerBook, even! - although the theming system can lag the slower machines in the stable pretty badly. You should really disable theming on anything single-core or slower than 1.4 GHz, and with on-board video.

But how come no one's brought up the real issue here, that we're running IPB? I hear IPB 4 is a trainwreck and have already seen another forum revert to 3.4 after upgrading. Sometimes I wish Acmlm had written a nice forum software instead of an OS... the world could be posting on "AcmlmForums" instead of messing around with broken IPB setups and the like.
StapleButter
Member
Level: 41


Posts: 167/486
EXP: 472033
For next: 8112

Since: 02-24-13

From: your dreams

Since last post: 26 days
Last activity: 4 days

Posted on 01-26-16 06:47:51 PM Link | Quote
Well, maybe phpBB isn't bad? well I heard it's backwards and weird...


In the meantime, I updated to the shiny new AcmlmOS 2.0. It's still a beta so some things are a little buggy, but the AcmlmOS team is fast at fixing all that, and so far it's really nice!

AcmlmOS users are generally concerned about security and resort to antiviruses and firewalls. I can tell you that those are almost uneeded with 2.0, it's already pretty secure on its own.

The new interface also looks pretty nice, gotta say. The bigger fonts make it easier to read.



goddamnit IPB! I had to try like 5 times to manage to post this...
Keitaro

Fire Snake
LOVELY ARRANGEMENT. VOLCANO BAKEMEAT
Level: 66


Posts: 1188/1191
EXP: 2455822
For next: 6029

Since: 09-09-08

From: California

Since last post: 98 days
Last activity: 64 days

Posted on 03-20-16 04:40:48 PM Link | Quote
I tried to download OS2 but the support community just sat around making dick jokes and flaming each other, so I heard the dev team split off the codebase in to a seperate OS just for us.
Sanqui
1720
🦉
Level: 76


Posts: 1409/1729
EXP: 4005157
For next: 903

Since: 12-20-09

Pronouns: any
From: Czechia (NEW!)

Since last post: 3 days
Last activity: 1 day

Posted on 03-20-16 05:02:22 PM Link | Quote
Originally posted by devin
Originally posted by StapleButter
You turn your computer on. You are greeted by the BIOS splashscreen

ah... the Fun POSTing Experience

Groan.
Starroad32

Level: 5


Posts: 3/7
EXP: 485
For next: 44

Since: 08-01-16

From: Look at my avatar ^_^

Since last post: 1.0 years
Last activity: 1.0 years

Posted on 08-01-16 02:38:12 PM Link | Quote
@StapleButter: phpBB2 was extremely backward for a long time, refusing to properly patch things as well as add several features. That's why SMF and MyBB have taken them over. phpBB3 is about tolerable in my opinion, but isn't the best.

Also, I saw someone mention AcmlmBoard 1.92. Just for a quick test, can I borrow a copy of it with a working installer? All the copies I found don't have a working installer.
RanAS
Member
Level: 38


Posts: 201/441
EXP: 340051
For next: 30396

Since: 10-10-14

From: Brazil

Since last post: 2 days
Last activity: 1 min.

Posted on 08-01-16 04:13:30 PM Link | Quote
IIRC AB1.92 has always been distributed as-is, and with next to no support or installer of any kind, so there never was one. If you want to install it successfully, you'll have to look at a further version like 2.5.x or one of the many forks/derived versions, like BoardC.

Although maybe someone could help you, it'll probably not be as simple as running an installer.
StapleButter
Member
Level: 41


Posts: 306/486
EXP: 472033
For next: 8112

Since: 02-24-13

From: your dreams

Since last post: 26 days
Last activity: 4 days

Posted on 08-01-16 04:22:39 PM (last edited by StapleButter at 08-01-16 04:23:11 PM) Link | Quote
the 1.92 copy that was on Acmlm's server came with a .sql file that installed everything right iirc. The board itself needed fixes because it was coded for PHP4 and older MySQL, though.

can't say as much about other versions, haven't tried them.

except for AB2.0a1, which was provided without any kind of install script. I took AB1.92's one back then and adapted it
RanAS
Member
Level: 38


Posts: 202/441
EXP: 340051
For next: 30396

Since: 10-10-14

From: Brazil

Since last post: 2 days
Last activity: 1 min.

Posted on 08-01-16 04:39:03 PM Link | Quote
Originally posted by StapleButter
the 1.92 copy that was on Acmlm's server came with a .sql file that installed everything right iirc. The board itself needed fixes because it was coded for PHP4 and older MySQL, though.

Ah, well I guess that's that. I remember people talking about 1.92 also having loads of security problems because of outdated code.

On another note, viewing the (somewhat broken) I2 archive reminded me about I1 and how it's still unaccessible.
StapleButter
Member
Level: 41


Posts: 307/486
EXP: 472033
For next: 8112

Since: 02-24-13

From: your dreams

Since last post: 26 days
Last activity: 4 days

Posted on 08-01-16 04:41:14 PM Link | Quote
not only outdated code but also careless coding, there's SQL injections all over the place for one, and the code relies heavily on register_globals

to fix it properly you'd have to, well, rewrite it
Kak
heh
Level: 71


Posts: 1564/1780
EXP: 3141998
For next: 25116

Since: 09-03-13

From: ???

Since last post: 6 days
Last activity: 1 day

Posted on 08-01-16 04:45:30 PM Link | Quote
IIRC 1.92.08 also comes with an install.php which acts as a "cleaner version" of the .sql install script.

There are less problems there than vanilla 1.92, but there are still many issues around.
StapleButter
Member
Level: 41


Posts: 308/486
EXP: 472033
For next: 8112

Since: 02-24-13

From: your dreams

Since last post: 26 days
Last activity: 4 days

Posted on 08-01-16 04:52:26 PM Link | Quote
1.92.08 seems to fix a few of the issues, like exploits in the cookie system, etc... and relies on magic_quotes (bad)
skyu

Level: 17


Posts: 20/90
EXP: 23193
For next: 1550

Since: 06-11-16

From: a grave

Since last post: 180 days
Last activity: 180 days

Posted on 08-01-16 08:08:12 PM Link | Quote
Originally posted by Schezo
IIRC 1.92.08 also comes with an install.php which acts as a "cleaner version" of the .sql install script.

huh. I could never get that script to even work, but eh, I doubt it ever did work anyway. or I'm doing it wrong.
Starroad32

Level: 5


Posts: 4/7
EXP: 485
For next: 44

Since: 08-01-16

From: Look at my avatar ^_^

Since last post: 1.0 years
Last activity: 1.0 years

Posted on 08-02-16 01:33:37 AM Link | Quote
I actually wasn't asking for myself, but saw cderp4 ask for the files on Board 2.
Just clearing that up.
Pages: 1 2Next newer thread | Next older thread
Jul - Craziness Domain - The OS of the future: AcmlmOS New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 5d36857 [2018-03-03]
©2000-2018 Acmlm, Xkeeper, Inuyasha, et al.

31 database queries, 8 query cache hits.
Query execution time: 0.178631 seconds
Script execution time: 0.027395 seconds
Total render time: 0.206026 seconds
Memory used: 1048576