Register - Login
Views: 86539349
Main - Memberlist - Active users - Calendar - Wiki - IRC Chat - Online users
Ranks - Rules/FAQ - JCS - Stats - Latest Posts - Color Chart - Smilies
10-20-17 05:54:11 PM

Jul - Meta - Email URL-encoding issues New poll - New thread - New reply
Next newer thread | Next older thread
StapleButter
Member
Level: 40


Posts: 92/460
EXP: 406664
For next: 34645

Since: 02-24-13
From: your dreams

Since last post: 4 days
Last activity: 4 days

Posted on 07-05-14 10:53:43 AM Link | Quote
My email showed up as: thetotalworm%40gmail.com (%40 replacing the @).

I figured it was some buggy feature against email harvesting, and changed it to: thetotalworm [at] gmail [dot] com

The following garbage showed up: thetotalworm+%5Bat%5D+gmail+%5Bdot%5D+com


There's an issue with URL encoding apparently.
dotUser

Level: 83


Posts: 2024/2240
EXP: 5361785
For next: 70436

Since: 10-19-10


Since last post: 13 days
Last activity: 1 hour

Posted on 07-05-14 12:17:22 PM (last edited by dotUser at 07-06-14 04:04:05 PM) Link | Quote
This issue seems to show up on occasions. It also used to affect text in normal plaintext fields that didn't turn things into URLs.

Kazinsal
Amazing Flyin' Hammer Bro
Level: 45


Posts: 505/543
EXP: 628439
For next: 31725

Since: 01-18-11
From: Victoria, Canada

Since last post: 74 days
Last activity: 70 days

Posted on 07-05-14 04:34:27 PM Link | Quote
On the plus side, most email clients will interpret the mailto link correctly even with the %40 in there.

Or, I'd assume most email clients would. Thunderbird does for sure.
Next newer thread | Next older thread
Jul - Meta - Email URL-encoding issues New poll - New thread - New reply




Rusted Logic

Acmlmboard - commit 2f1bc75 [2017-08-27]
©2000-2017 Acmlm, Xkeeper, Inuyasha, et al.

26 database queries.
Query execution time: 0.122391 seconds
Script execution time: 0.004125 seconds
Total render time: 0.126516 seconds